Bug with File and Image upload

  • Author
  • #1716


    I tried to upload a photo named PDR_0220.sized.jpg. It would not uploa. WordPress said “cannot upload file of this type”. After changing the name to PDR_0220.jpg it uploaed fine.



    I’d guess that the . in the filename led WordPress to believe that you were uploading a ‘sized.jpg’ rather than a ‘.jpg’. Not really a bug, just a reminder that periods are best kept out of filenames :)



    It should only look at the last bit, I’ll add this to the bug list.



    It was thrown off by the multiple dots but it should now handle any number of dots in a valid filename.



    wank: lol. do you or did you at any point in your life work for MS? ;)

    matt, andy: thanks for looking to fix.



    I’m trying to upload some mp3 files, like I did in my older posts. Today, when I was uploading the file, I got the “timeout” message in the browsers (Firefox e IE 6).
    The controls of bold, italic, and the others have vanished too… Is this an error or a bug???

    Sorry for my poor english…

    From Brazil,

    Fabio Calsavara



    I’m having problems just uploading images tonight. The image upload tool shows up… I choose an image to upload… hit the upload button… and the tool disappears w/o uploading anything. I’ve tried 4 different browsers and it works the same with all three of them.

    Is it down tonight or am I just missing something? haha.



    Calsavara, mp3 files are not allowed to be uploaded to WP.com space. Not sure how you pulled it off earlier but last time I checked, *.mp3 is on the ban list. You can link to them hosted elsewhere though.

    Red, since I don’t see any other threads on this topic so far, I’m assuming that it’s an issue with your share of the server. I would send in a feedback so staff can take a look at it. It may also just be a temp glitch or a lockdown while they do something on your box.

    Good luck,



    Thanks, Mike!

    I’ve uploading .mp3 files normally, but if this kind of file is banned, I’ll try other ways tod do it (linking to other hosts). But I’m having trouble uploading photos too. No way to upload them. “Connection timed out”, is all I have from my browsers (Firefox & Explorer).

    However, thanks again for the tip.



    im having the same problems uploading files (jpg,pdf)
    m getting an error msg in the uploading tool frame:
    “The connection was reset – The connection to the server was reset while the page was loading.”
    On the page with that error msg, I have a “try again” button.
    I keep hitting on that button and sometimes I manage to upload.
    I`m using FireFox on winXP SP2

    When using Internet Explorer 6 (updated)
    I get a “the page could not be displayed” in the same place as displayed above.



    Well, if you’re having the same problem, I guess removing the ‘.sized.’ from your file name would help as stated above. :)

    I’m thinking though you’re having a different problem.

    Does it have any weird characters in the file name? (You may even want to state the file name here)

    Do you have javascript turned on and flash installed?

    What’s your ISP? Are you coming in via or from behind some sort of proxy or cache server?

    Have to checked to see if your picture made it? (ie clicked on the ‘Browse All’ link)



    my filename for example is: “Minor Scale.pdf”
    and the path I am uploading it from is:
    “C:\Documents and Settings\erik\Desktop\tmp”
    I tryed to change the path & filename but that did not change the result.

    I have JS and flash installed and working properlly.
    I do not use any proxy server and I have tryed it with 2 different ISPs.
    Could it be related to the fact that Im connected using an Israeli ISP?
    ve heard in Israeli forums, that this thing happens to others to.



    shalom sheket,

    it’s nowise related to the orgin of your connection.



    Allowing pdf uploads was being considered a month ago, looks like they decided against it.



    10nX wank,
    that’s weired, I already uploaded 5 pdfs to my blog.
    and as I mentioned before, the problem also happens with JPGs.



    Again, whats the name of the jpg please?

    Have you tried it without the spaces in the file name? (Some have reported issues with spaces in the file name in the past)

    Again, have to checked to see if your picture made it? (ie clicked on the ‘Browse All’ link)

    Again, What’s your ISP?

The topic ‘Bug with File and Image upload’ is closed to new replies.