Need help? Check out our Support site, then


can not edit my blog

  1. this afternoon I tried to edit post in my blog. after the editor loaded the page became not responsive.

    every page in that blog is like that. other wordpress.com blogs I have are O.K.

    tried in other browsers, run ccleaner and antivirus and restarted. nothing helps.

    Please, it is very important for me

    thanks!

    The blog I need help with is nirsternaristotle.wordpress.com.

  2. I can use WP control panel, delete post or post new post. just cannot edit.

  3. now I tried the old editor, via control panel, and it works

  4. I am having the same problem - unable to edit pages (but still can edit blog "posts"). How do you open the "old editor"? Thanks

  5. hi
    in control panel under all posts you see list of the posts
    than select the post and select edit

    good luck!

  6. @queenscreen, please disregard nistern's directions. To go to the classic editor (the one that predates the current not-so "improved" editor), add /wp-admin after your blog's main url. (see format below). That takes you to your "dashboard" page. (Bookmark this!)

    Then click on POSTS in the sidebar. Or on "add new" in the drop-down under posts if you want to create a new post.

    If you click on POSTS or ALL POSTS, a very useful list of all your post appears, with columns showing their individual stats, tags, categories etc. You can click under any post to edit it, and the old 'classic' editing page will appear, which I prefer over the new editor myself.

    https://YOURBLOGNAMEHERE.wordpress.com/wp-admin/

    Good luck!

  7. In looking through old support forum posts I found the same instruction on getting to the old editor. I did try it and it worked fine, so thanks! (But I'd still like to know how to unfreeze the new editor...)

  8. There is an annoying bug in the new editor page since yesterday afternoon sometime. As soon as I go to the (new) editing page, everything freezes, then a pop-up appears (in firefox, anyway) saying:

    A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

    Script: https://wordpress.com/calypso/…ld.e91dcd855f809bc562ed.min.js:71

    If I click to 'stop script' or to 'continue', the page eventually unfreezes after a wait, but dumps me at the very bottom of the page (I'm working on a long post and editing early bits of it, so this is annoying).

    For reasons too complicated to explain I am choosing not to use the classic editor right now even though I much prefer it, so am grumping along with this very time-consuming delay each time I try to update my in-progress post.

    Here's a link to a screen shot of the pop-up message.

  9. @queenscreen, didn't see your last post while I was uploading my screenshot! In firefox if I click on one or the other of the two options in that popup it gives me, it does get me past the frozen screen but the whole thing takes a few minutes. I've tagged this thread 'modlook' (over on the right side) so a staff person should look at it fairly soon, and hopefully get this fixed or tell us what's up...

  10. correction to what I posted above.

    It turns out I must choose "continue" rather than "stop script" in that popup. If I choose "stop script", the screen appears to unfreeze and allow me to edit, but if I then make any edits, nothing happens when I click "update". Frozen again.

    If I click "continue" on the popup, there's a bit longer of a wait, but once the screen unfreezes and allows me to make changes, clicking on UPDATE does work.

  11. Can you all confirm which browser you're using?

    Also are you all getting the same error at WordPress.com?

  12. @ingridcc if you're in Chrome can you test using a new incognito window to see if you get the error there as well?

  13. I'm using Chrome

  14. @supernovia, not sure what you mean by this?

    Also are you all getting the same error at WordPress.com?

    Do you mean, are we all getting the same pop-up error message?
    Or do you mean "is everyone on WordPress.com getting this problem"?

  15. I opened a Chrome incognito window and the new wp editor still freezes.

  16. I'm using firefox. Don't have Chrome. I'm not so eager to install another browser if I don't have to... @queenscreen-you use Chrome, do you get any kind of error message with this?

  17. After 20-30 seconds I get a message from Chrome saying the page is stalled, and asking whether I want to wait or continue.

  18. Sorry, wait or EXIT. I've tried waiting, but it never unlocks.

  19. I'm getting the same issue, also on Chrome. After a few seconds the page freezes and Chrome asks if I want to wait or continue. Waiting doesn't unlock it. I'm using the most current version of Chrome, it looks like (Version 62.0.3202.94 (Official Build) (64-bit) <- what it says in the settings page) if that might help at all.

    Getting to the classic editor that @ingridcc gave instructions on how to get to lets me edit posts without the same issue.

  20. Thanks folks. Can anyone confirm whether this happens on every post or just some posts? If you make a test post does it happen there?

  21. For me, it freezes when editing SITE PAGES - the new editor still works when updating BLOG POSTS.

    I just was able to add a new PAGE in the new editor, but when I tried to update an old page it became non-responsive after a few seconds.

  22. I have been primarily editing a post (not a page) that is published as 'private' or maybe it's called 'admin only' in the new editor.

    But I also did some edits to two other older, published posts and the same thing happens with them. Edit page freezes, during which time I also can't go anywhere else - like if I click on another tab I have open I can't go there, everything's stuck til the popup error mssg comes up.

    Once, inexplicably, the edit screen did NOT freeze up and the update went through as if everything was normal, so I thought the problem had been fixed. But that turned out to be a fluke, the edit screen has frozen every time since. It takes half a minute or so for the popup error mssg to come, then another half a minute to process after I click 'continue' then sometimes the same error msg popup comes back a second time but more often the edit screen starts working before that happens.

    This is a bummer because of the 'featured tag' problem in another thread I am trying not to use the old classic editor to find out whether or not it has anything to do with THAT problem, so now I am stuck with this new editor and this is happening!

  23. Ok this is weird!
    I made a new test post - set to admins only - in the new editor. No problem.
    Opened it and clicked lower right 'edit' popup to edit the way I usually do.
    No freezing! Edit screen worked fine.
    I did this 4 times, four successful edits.

    Meanwhile, my 'real' post still freezes up immediately.
    I only published it a couple weeks ago Oct 27. Have only worked on it in the new editor.
    The other ones I've done a couple edits today and gotten the frozen screen are older - published sep 13 and oct 3 this year. Published those mostly using the classic editor.

    Only difference I can think of is that the test post is only a few lines long, whereas my other posts have a LOT of text, plus some images.

  24. correction:
    My 'real' post's edit page freezes up immediately...

  25. i use chome. but tried in edge and firefox. it's the same.

    for me, one blog have the problem in all post, even new test posts.
    other blogs are OK.

  26. Thanks, folks. We are trying to figure out the cause here so this feedback is helpful.

    Are all of the pages you're trying to edit rather large? Do they have lots of text, lots of images, or both?

  27. My 'real' posts all have lots of text, some rather large photos, and all have an unusually large number of links to other posts on my blog. 2 of the 3 I've seen the problem on have lots of same-page jump - type links as well, but the most recent of the 3 has none of those yet. My site is instructional, and is also the main source of information on its topic so each post has a lot of links to other posts. The test post of a few lines that I made yesterday had none of that. It's edit screen has never frozen any of the 4 or 5 times I've updated it. I do have a few old 'brief notice' type posts - I will go check to see if their edit page freezes up.

  28. my posts are large.
    today everything is OK.
    maybe the problem solved

  29. Well surprise - I just went to my blog for the first time this morning, and the editing page works for everything! (at least the two posts I've checked so far)
    The wierd thing is that Firefox seems to have to done some massive update where everything on my screen looks totally different, my tabs are big and clunky-looking sort of old-school, and I'm missing some of the bookmark type tabs I usually have on my browser toolbar. But at least the main post I've been working on has no problem in its editing screen right now.

  30. @ingridcc and @nirstern our developers were able to find and fix the issue, thanks to your feedback and feedback from other users. Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags