can not edit my blog

  • Author
    Posts
  • #3046450

    nirstern
    Member

    this afternoon I tried to edit post in my blog. after the editor loaded the page became not responsive.

    every page in that blog is like that. other wordpress.com blogs I have are O.K.

    tried in other browsers, run ccleaner and antivirus and restarted. nothing helps.

    Please, it is very important for me

    thanks!

    The blog I need help with is nirsternaristotle.wordpress.com.

    #3046602

    nirstern
    Member

    I can use WP control panel, delete post or post new post. just cannot edit.

    #3046604

    nirstern
    Member

    now I tried the old editor, via control panel, and it works

    #3046614

    queenscreen
    Member

    I am having the same problem – unable to edit pages (but still can edit blog “posts”). How do you open the “old editor”? Thanks

    #3046615

    nirstern
    Member

    hi
    in control panel under all posts you see list of the posts
    than select the post and select edit

    good luck!

    #3046621

    ingridcc
    Member

    @queenscreen, please disregard nistern’s directions. To go to the classic editor (the one that predates the current not-so “improved” editor), add /wp-admin after your blog’s main url. (see format below). That takes you to your “dashboard” page. (Bookmark this!)

    Then click on POSTS in the sidebar. Or on “add new” in the drop-down under posts if you want to create a new post.

    If you click on POSTS or ALL POSTS, a very useful list of all your post appears, with columns showing their individual stats, tags, categories etc. You can click under any post to edit it, and the old ‘classic’ editing page will appear, which I prefer over the new editor myself.

    https://YOURBLOGNAMEHERE.wordpress.com/wp-admin/

    Good luck!

    #3046622

    queenscreen
    Member

    In looking through old support forum posts I found the same instruction on getting to the old editor. I did try it and it worked fine, so thanks! (But I’d still like to know how to unfreeze the new editor…)

    #3046623

    ingridcc
    Member

    There is an annoying bug in the new editor page since yesterday afternoon sometime. As soon as I go to the (new) editing page, everything freezes, then a pop-up appears (in firefox, anyway) saying:

    A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

    Script: https://wordpress.com/calypso/…ld.e91dcd855f809bc562ed.min.js:71

    If I click to ‘stop script’ or to ‘continue’, the page eventually unfreezes after a wait, but dumps me at the very bottom of the page (I’m working on a long post and editing early bits of it, so this is annoying).

    For reasons too complicated to explain I am choosing not to use the classic editor right now even though I much prefer it, so am grumping along with this very time-consuming delay each time I try to update my in-progress post.

    Here’s a link to a screen shot of the pop-up message.

    #3046626

    ingridcc
    Member

    @queenscreen, didn’t see your last post while I was uploading my screenshot! In firefox if I click on one or the other of the two options in that popup it gives me, it does get me past the frozen screen but the whole thing takes a few minutes. I’ve tagged this thread ‘modlook’ (over on the right side) so a staff person should look at it fairly soon, and hopefully get this fixed or tell us what’s up…

    #3046630

    ingridcc
    Member

    correction to what I posted above.

    It turns out I must choose “continue” rather than “stop script” in that popup. If I choose “stop script”, the screen appears to unfreeze and allow me to edit, but if I then make any edits, nothing happens when I click “update”. Frozen again.

    If I click “continue” on the popup, there’s a bit longer of a wait, but once the screen unfreezes and allows me to make changes, clicking on UPDATE does work.

    #3046631

    supernovia
    Staff

    Can you all confirm which browser you’re using?

    Also are you all getting the same error at WordPress.com?

    #3046634

    supernovia
    Staff

    @ingridcc if you’re in Chrome can you test using a new incognito window to see if you get the error there as well?

    #3046635

    queenscreen
    Member

    I’m using Chrome

    #3046636

    ingridcc
    Member

    @supernovia, not sure what you mean by this?

    Also are you all getting the same error at WordPress.com?

    Do you mean, are we all getting the same pop-up error message?
    Or do you mean “is everyone on WordPress.com getting this problem”?

    #3046638

    queenscreen
    Member

    I opened a Chrome incognito window and the new wp editor still freezes.

    #3046639

    ingridcc
    Member

    I’m using firefox. Don’t have Chrome. I’m not so eager to install another browser if I don’t have to… @queenscreen-you use Chrome, do you get any kind of error message with this?

    #3046640

    queenscreen
    Member

    After 20-30 seconds I get a message from Chrome saying the page is stalled, and asking whether I want to wait or continue.

    #3046642

    queenscreen
    Member

    Sorry, wait or EXIT. I’ve tried waiting, but it never unlocks.

    #3046645

    voxelroar
    Member

    I’m getting the same issue, also on Chrome. After a few seconds the page freezes and Chrome asks if I want to wait or continue. Waiting doesn’t unlock it. I’m using the most current version of Chrome, it looks like (Version 62.0.3202.94 (Official Build) (64-bit) <- what it says in the settings page) if that might help at all.

    Getting to the classic editor that @ingridcc gave instructions on how to get to lets me edit posts without the same issue.

    #3046655

    supernovia
    Staff

    Thanks folks. Can anyone confirm whether this happens on every post or just some posts? If you make a test post does it happen there?

The topic ‘can not edit my blog’ is closed to new replies.