Cannot add specific media from Google Photos

  • Author
    Posts
  • #3012638

    imintii
    Member

    I have about two hundred photos on Google Photos. When I go on to the ‘add media from google photos’ option, it only shows about 20 photos from a week ago. I have taken photos every day since then, and none show up. Photos before that don’t show up either. I have read the ‘How do I add Google Photos to my site?’ question, and it explains that only 1000 photos can show up without searching. But I only have 20 or something showing up? Sorry if I am missing something really obvious, I am new here.
    Thanks,
    Minty.

    The blog I need help with is lifeasmintii.wordpress.com.

    #3012873

    justjennifer
    Moderator

    Hi there, this is also a relatively new feature here on WordPressdotcom so we’re probably ironing out the wrinkles. :)

    Here’s what it says in the support guide to this feature:

    It can take some time for newly uploaded Google photos to be made available for us to show in the media library – don’t worry, they will appear! You can press the ‘refresh’ button to reload your photos.

    I’ve gone ahead and tagged this for Staff review and input. Thanks for your patience while they reply.

    #3012878

    kokkieh
    Staff

    Hi there,

    We recently added a Refresh button for Google Photos in the media library. Can you please try that and see if it loads the other photos?

    Click on My Site ->Media. Click the W icon top left and select Google Photos. Click Refresh. Do the rest of the images appear?

    And can you access the other images by searching for them?

    #3012879

    kokkieh
    Staff

    Hello again :)

    I asked one of our developers to take a look at this, and it seems Google’s API is not returning all available images in the connected account in some cases. The images should still appear if you search for them, though.

    We’re looking into it, but it might not be a simple fix.

    #3012899

    kokkieh
    Staff

    Hi there,

    I heard back from the developer working on this and it appears the problem is on Google’s end. They just sometimes don’t return all the photos in your account, though all the photos should be searchable.

    As you upload new photos to Google the issue might resolve itself – that has been our experience thus far with cases like these. We’re also speaking with Google to see if there’s something they can do on their end, but for now this is a glitch in the feature that we have to live with :)

    #3012900

    justjennifer
    Moderator

    Thanks for the update, @kokkieh.

    #3012913

    Hi,
    I have the same problem, refresh and search are both not working for me. Not only the latest photos are missing but I have bigger holes, sometimes half a day, sometimes a complete day is missing.
    Jan

    #3012914

    kokkieh
    Staff

    @janblessenohl

    I understand this is frustrating, but this is a problem with Google’s API, so it needs to be fixed on their end.

    All images should be there if you try searching for them. You can search for file names, but this feature also uses Google’s image identification tech so searching for “dog”, for example, should return all images in your library that contains a dog in some form or other.

    If Search is not working, can you please go to My Site ->Sharing and disconnect your Google Photos account, and then try reconnecting? Also clear your browser cache and cookies to make sure it’s not a browser issue.

    #3012915

    Hi kokkieh,
    I did all this several times, no changes on my side.
    Jan

    #3012916

    kokkieh
    Staff

    Hmm. I checked your account on our end, and it’s loading the 100 most recent photos for me (that’s the limit of how many photos we can show without searching) with no gaps in the dates, so I still wonder if something in your browser might be interfering with the code that makes this feature work.

    What browser do you normally use? Can you please make sure that JavaScript and third party cookies are enabled, and try disabling any ad-blocker or anti-malware extensions that might be running in the browser.

    Can you also please check what happens if you log in in incognito mode in Chrome, or using a different browser than you normally use?

    #3012917

    Hi kokkieh,
    I am using Edge and Chrome, tested both with empty cache and inkognito, no changes. I see some pictures of a day but not all and some days are missing. My feeling is that it started when you have added the dates in the grid.
    Jan

    #3012918

    Howdy –

    I’m going to take over for @kokkieh here.

    Can you verify that you have checked the following:

    Can you please make sure that JavaScript and third party cookies are enabled, and try disabling any ad-blocker or anti-malware extensions that might be running in the browser.

    Have you tried using a different browser already?

    #3012919

    Hi lizkarkoski,

    yes, tried all this.

    Jan

    #3012920

    Thanks Jan :)

    Have you uploaded any new Google images since getting in touch with us? That has resolved the issue for other users before.

The topic ‘Cannot add specific media from Google Photos’ is closed to new replies.