Need help? Check out our Support site, then

cannot create new account on

  1. antonellasevero


    I am trying to create a new blog on (free) and it's not letting me. I enter all the information, it gives me a green check as available, I select the free version of the URL, and then I check the FREE BLOG button at the bottom. It refreshes the page, but then doesn't do anything else.

    At this point, all the buttons at the bottom are grayed out as well and all the fields are marked with a green check.

    It seems to be in a loop. I can't figure out what else is going on. Is it possible that we can't create new accounts during the holiday period?


  2. Hi Antonella,

    You definitely should be able to create a new account and/or blog during the holiday period. :) I'm sorry you're having trouble with this!

    Are you trying to create a new blog on the same account, or are you trying to set up a completely new account?

    Can you also double-check to make sure that each of the items in the signup form have green checks next to them, and there aren't any error messages on the form? If everything is filled out correctly, the buttons at the bottom shouldn't be grayed out anymore and you should be able to click them to create your blog.

    If you've checked those and you're still having trouble with this, please let me know and we can keep investigating this for you.

  3. antonellasevero

    Hi. Thanks for your response. To answer your questions:

    1) This is for a completely new account with a new email.
    2) each item has green checks on all and no obvious error messages

    I've posted 2 screenshots (with info smudged out) so you can see the results.
    Step 1: Enter all information, get green checks, click on blue CREATE BLOG button at bottom.
    Step 2: Page refreshes, but nothing happens. Buttons now grayed out. Field info still has green check marks. No apparent error messages.

    Hope this helps in identifying the problem. Would love to get going on a new project soon :)


  4. antonellasevero

    Sorry, wrong link on Step 2. Here is the NEW LINK.

  5. Hi Antonella,

    Thanks for those screenshots — it does look like something's going wrong there. I just emailed you so we can discuss some private details about your signup. Can you reply to that email so we can keep troubleshooting this for you? Please let me know here if you don't get the email from me. :)

  6. antonellasevero

    Problem solved! After troubleshooting this with Rachel via email, we discovered that my password was only numbers. I added upper and lower case letters and it worked instantly.

    For future tweaks, it would be helpful if a true error message is shown by the field that indicates the problem.

    Thanks so much for helping me to troubleshoot this...

  7. I'm so glad we figured this out. :) I'll follow up with our team to find out why the password error message didn't appear for you.

    I also want to note for anyone coming across this thread that Antonella did not tell me the password she was trying to use. staff will never ask you for your password. Keep it secret — keep it safe! :)

  8. @rachelmcr - as the OP mentions a bit of fine tune on BOTH the error message and the part about Passwords

Topic Closed

This topic has been closed to new replies.

About this Topic