Cannot insert image or text into post

  • Author
    Posts
  • #1248590

    I’m in the course of writing a new post. I want to insert sections of text I wrote in Word, but every time I insert a paragraph (using either simply ctrl C / ctrl V or the insert from Word function in the editor), another paragraph disappears, and the draft reverts to a previous version. Similarly, I cannot insert images from the gallery – when I try, the image doesn’t appear, only a little line, and some of the text above it disappears.
    I have tried two different browsers and clearing cookies.

    The blog I need help with is hungarianarthist.wordpress.com.

    #1248714

    timethief
    Member

    Microsoft Word is a word processing program that’s not compliant with web standards. The result of copy and pasting from Microsoft Word into the Tiny MCE editor in WordPress blogs can be unexpected, and contain a lot of formatting code that’s not compliant unless you know how to use the built-in features in the Visual editor for using Word cleanly. http://en.support.wordpress.com/visual-editor/#pasting-text

    Note you need to click the kitchen sink icon #15 at the end of Row 1 to have Row 2 appear. http://en.support.wordpress.com/visual-editor/#row-1

    Go here and enable this > Settings > Writing
    Formatting
    _ WordPress should correct invalidly nested XHTML automatically
    “save changes”

    I recommend using Windows Live Writer for posting to your blog > http://en.support.wordpress.com/xml-rpc/windows-live-writer/

    #1248719

    Thanks for your response. As I said, I have tried pasting it via the “paste from Word” function in the kitchen sink, but the result was the same. Also, this still doesn’t explain why I cannot insert images.

    #1248721

    timethief
    Member

    For troubleshooting images see http://en.support.wordpress.com/images/troubleshooting-images/

    You can upload image files in two ways: by going to Media → Add New from your dashboard http://en.support.wordpress.com/media/media-add-new/ or by clicking the new Add Media button right above the editing area of a page or a post. http://en.support.wordpress.com/add-media/

    See also http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

    #1248722

    I really appreciate your answers, Timethief, but this still doesn’t help. I can upload images – I just cannot insert them. This is my 11th post, and it is an art history blog – I have already inserted lots of images without problem, and I know how to do it. This is a new issue.
    Thanks again!

    #1248724

    timethief
    Member

    I tagged this thread for Staff help.

    They need to know exactly what happens when you attempt to insert them?

    They also need your step by step reports back on the following troubleshooting steps.

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

    #1248731

    Thanks! I am using Opera 12.12 and Chrome 26 – I have the same problem with both. I have tried clearing the cache. I have cookies enabled, and I don’t have any extensions or add-ons that I know of.
    I don’t get error messages – it just simply doesn’t work the way it should.

    #1248874

    macmanx
    Staff

    Just so we can rule-out any browser-specific issues, would you please try in Firefox or Explorer?

    http://browsehappy.com/

    #1248882

    I tried Firefox 20. Still the same problem. :(

    #1248894

    macmanx
    Staff

    This is rather odd. Would you please give us a link to the post or page where you can’t insert images?

    #1248895

    The post is still a draft.
    I tried inserting the image from my phone and that worked! Which means the problem might lie with my computer. But what could it be?

    #1248896

    macmanx
    Staff

    What is the title of the draft?

    #1248897

    The Baedeker of the Soul: Love, Manipulation, and Hungarian Gothic

    #1248898

    macmanx
    Staff

    Take a look at those last two paragraphs in the editor’s Text tab (not the visual tab). They’re full of “span” formatting tags which will cause all sorts of trouble.

    It’s one of the reasons why we don’t recommend copying from word processors, because this formatting junk comes a long and causes its own trouble.

    Try re-entering just those paragraphs in the Text editor tab so you get just the text and none of the other junk.

    #1248899

    Ok, thanks, this seems to have solved it, although I think I will have to start a completely new post because it still doesn’t let me insert images. I looked at the Text tab after I tried to insert an image (which only shows up as a little line in the visual editor), and I saw that instead of the image, it inserts something with the same “span” tags.
    I usually write my posts in Word and copy the text paragraph by paragraph using the “paste from word” function, but I might have forgotten to use it for 1-2 paragraphs now, and that’s probably when it got messed up. I think I will start using Live Writer.
    Thank you very much for your help!

    #1248900

    macmanx
    Staff

    You’re welcome!

    #1248908

    Sorry, but this still isn’t resolved after all. I wrote my post in Live Writer, transferred it to WordPress, then tried to insert images, but it didn’t work. Even if I start a brand new post and try to insert an image, it doesn’t work. Instead of the image, I get this: <span id=”__caret”>_</span>.

    #1248909

    timethief
    Member

    Are you clear on the fact that you must upload the images off your computer into the posts ie. onto WordPress.com servers?

    #1248910

    Yes. In fact, as I said, this is not my first post, and I have uploaded and inserted quite a lot of images before. I am doing it the same way as I always did.
    The images are uploaded to the WordPress gallery, but when I try to insert them from there, the thing described above happens. I can, however, insert them from my phone.

    #1248913

    asterix53
    Member

    I also experience the same problem; I can upload an image to the media section, but when I try to tell it where to attach it it doesn’t respond, nor il lets me paste it directly. I cannot insert imag es; I put on the site recently, it’s address is http://www.claudiomaddaloni.net, and used to post on a blog on wordpress before and it di work with previous versions of wordpress; maybe this version has a bug? let ne know please, thank you , at
    (email redacted)

The topic ‘Cannot insert image or text into post’ is closed to new replies.