Cannot post from Mars Edit to WP blog => Password

  • Author
  • #999814

    So I love WP, but I have a problem using Mars Edit for offline blogging/posting.

    I think I have the settings correct in Mars Edit, but when I try to post a blog post from Mars Edit to WP I keep getting a popup window asking me to insert password. I have entered the password in all the needed places in Mars Edit. After sending a support mail to M.E, I got a reply that said “The error messages you are getting are probably rooted in something not quite right in the WordPress configuration. For example the message you are getting “sorry, you are not allowed to publish
    posts on this site” is not an error message from MarsEdit, but is coming directly from the WordPress server.

    Is there anything at all you can think of that might be unusual about the account you are connecting with? Is it possible it has a “role” that is such that editing posts is not allowed? Alternatively, do you think there might be a plugin installed that could be interfering with normal functionality of WordPress?”

    Now, I really need help, as I really have no clue as to what to do about this.

    Thanx for helping

    Christer Berentsen

    The blog I need help with is


    I don’t think there are forum volunteers who use Mars Edit (or Ecto) based on questions I asked on July 8 that weren’t answered, and staff closed the post.

    Having said that – I am again demoing Mars Edit to make a decision, and I am able to post from the program to the blog, and don’t get the pop-up you are. (I just checked again, and it worked.)

    I presume you are the administrator of your blog, I think that is what the ME email refers to.

    Are you able to “refresh” Mars Edit, so that all your blog posts/pages show up in the program?

    In case this helps – based on my settings under Blog/Edit settings, see if yours match this:

    Blog name: Lost Biker

    System Name is: WordPress
    System API is: WordPress API

    API Endpoint URL:

    Blog ID: 1

    Those all were autodetected by Mars Edit when I added the blog to the program, so if yours aren’t the same, perhaps try deleting the blog in Mars Edit, and starting over.

    I only needed to enter the password once, when I first added the blog to ME.

    I wish I could help, hopefully checking the settings will at least give you more info to go back with to ME and ask again. If there is anything else you’d like me to check, I’m happy to.


    Hey sensuousinkspiller

    Thank you SO much!
    That did the trick! Removed, added again and Bobs you uncle!

    Thanx a bunch!



    YAY! I’m so glad it worked. You’re welcome!

The topic ‘Cannot post from Mars Edit to WP blog => Password’ is closed to new replies.