Cannot remove Home page

  • Author
    Posts
  • #2229188

    anoukkoray
    Member

    I have just started putting together this new blog, and have set that the ‘About’ page should be the static front page. But when I preview the blog, there is still also a Home page tab, which is a duplicate of the About page. I don’t need both but the Home page is not listed in the ‘pages’ section to be able to remove it. What am I missing here?

    The blog I need help with is cottagesupperclub.wordpress.com.

    #2229286

    timethief
    Member

    You have two choices on any blog
    (1) All posts on the front page.
    (2) A static front page and posts on a different page.

    By default the front page of your blog displays all published posts (not pages) in reverse chronological order, with the most recently published post on top. That is for the convenience of your returning visitors.

    However, if you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts. To do that create two pages first http://en.support.wordpress.com/pages/

    After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    A static page (select below)
    Front page:
    Posts page:

    #2229287

    timethief
    Member

    You can create a custom menu and add links to only the items you want to include in it. http://en.support.wordpress.com/menus/

    #2229363

    anoukkoray
    Member

    Thanks timethief. I get that there needs to be a separate page for the posts, if the main front page is static. My main static homepage is called ‘About’ and is set as the static front page in the settings. The posts are set to go to a page called What’s Happening, and this is also set in the settings.

    Settings are set to show:

    Front page displays as a static page – About
    Posts page – What’s Happening

    There is no page called Home, but it still shows on the blog tabs.

    #2229481

    anoukkoray
    Member

    Hmmmm….I’ve sort of fixed it, by using the menu option, but I’ve got a couple of other blogs where I’ve set them up exactly them same and not had to do it this way before. Ah well – not quite sure what I’ve done differently this time but at least I no longer have two pages called Home and About, that are duplicates of each other.

    For the record, when I clicked on ‘view all’ under the menu options, there were 2 ‘Home’ pages listed – one as ‘Home: About’, and one just as ‘Home’. I used the menu options to only show the ‘Home: About’ and the duplicate tab is now gone.

The topic ‘Cannot remove Home page’ is closed to new replies.