cannot see stats

  • Author
  • #984226

    Every time I click the link to view my stats – and sometimes when I try to go to my Dashboards – I’m taken to the Freshly Pressed page. I’m definitely logged in – my icon is up at the top right with all the links. I just can’t seem to do anything but delete SPAM from my blogs. Something up?

    The blog I need help with is


    I should clarify that there are no tabs to my blogs or anything else on the Freshly Pressed page; no way to navigate to the blogs except from the menu under my image at the upper right -which takes me back to the Freshly Pressed page…



    Our Stats are being moved to the home page of
    You can still access them in your dasboard here



    Thanks for the clarification.

    (1) How you are connecting to the internet and to

    Note: The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers. Also note that the main dashboard isn’t designed to work with touch devices through the tablet and smartphone browsers.

    (2) Exactly which browser and version of it are you using. If you don’t know click here to find out >

    Note: If you are using IE9 in compatibility mode that means it renders as IE7 and IE7 is not supported.


    I’ve tried both Firefox 13 & MSIE 9. Neither shows the tabs to my blogs on the Freshly Pressed page like they used to, and when I use the navigation links under my image in the upper right corner of the window, sometimes it takes me where I want to go, usually takes me to the Freshly Pressed page. If I click the link for Stats, or if I click the graph at the upper left of the window for Stats, I get bounced to the Freshly Pressed page.

    I have tried every way I can to log in and resolve this – from, from, from the Freshly Press page using the login boxes in the upper left corner of the window… It at first didn’t show that I was logged in, left me on the Freshly Pressed page with no indicator that the login worked. When I entered my blog address, my blog gave me no admin functions, so I headed back to try to log in again and finally got the icon and links in the upper right.

    If there are housekeeping chores going on behind the scenes, I’m willing to chalk it up to that and see if it straightens out when the work is done.

    Thanks for replying!


    Oh, also, I’m on a desktop machine, not on a mobile device.



    Please upgrade that outdated dated Firefox 13 browser here
    Then log in directly to your own blog using the https:// login
    See here for the explanation >


    Updating the Firefox browser is not an option, since it’s my work browser and I don’t have admin authority. But adding the s to http made all the difference in MSIE – I can view the stats now.

    Thanks much!



    Yes! I love happy endings :) You’re welcome.


    Why aren’t the stats working on the WordPress App? I keep getting some lame message about my JetPack?


The topic ‘cannot see stats’ is closed to new replies.