Cannot select home and post pages in settings

  • Author
    Posts
  • #826355

    loiswakeman
    Member

    Hi, I just created a new blog and published 8 skeleton pages, and a single post to use on the news page. Using the default theme.

    When I go to settings > reading, all I can select for the home and post pages is the original “about” page that was created with the blog, which I have since renamed anyway.

    Tried logging in and out again, no change.

    Please can you help?

    TIA

    The blog I need help with is westleybedandbreakfast.wordpress.com.

    #826492

    hnsaifi
    Member

    Please be specific what are you asking about. Do you want to show the post on the homepage instead of news page?

    #826500

    loiswakeman
    Member

    Sorry, I thought I was but on re-reading, could have done better.:-)

    The blog was set up in its default state i.e the “About” page that is auto-created is the default posts page and the home page.

    I have renamed “About” to “Home”, and created other pages, including “News”.

    I want the home page to be the static page “Home”, and the post page to be the new page “News”.

    But in the settings, the drop-down list of pages for the static home page, and the posts page, both include the single item “About”, so I can’t use the second option to have different home and post pages.

    I hope that is a bit clearer?

    #826520

    hnsaifi
    Member

    Thanks for explaining it well.
    Well that seems tricky. I think it’s because you don’t have anything on those pages.
    You’ll have to chose a post page other than homepage. I don’t know why “News” is not appearing in the list. A senior member can tell you more about it.

    #826545

    loiswakeman
    Member

    That’s the problem: the post page I want isn’t in the list to choose from! Just the (old) home page. Anyway, thanks for trying to help!

    #826563

    The page has to be published and not set to private before it will show up in the list to be used as the “posts” page. Make sure that “home” and “news” are published and not set to private.

    #826569

    loiswakeman
    Member

    Thanks for the tips – but I already checked that! I got this to work on other blogs,but perhaps it will sort itself out eventually. Apologies if I don’t reply to any more but I am logging off for the weekend now :-)

    #826666

    loiswakeman
    Member

    In time honoured fashion, if you go away and leave something, then come back to it a few days later, it has fixed itself. Matter closed.

The topic ‘Cannot select home and post pages in settings’ is closed to new replies.