Cannot Set Blog as a Featured Page

  • Author
    Posts
  • #3262975

    lagarten
    Member

    Following the steps for the Edin template, I have created a static homepage with three featured pages. Since the homepage is static, I moved my blog to a different page using the Theme Options. I want to make this blog one of the featured pages on the static homepage.

    However, when I select the blog as a featured page, only the first post from my blog shows up as the featured page. This means that when users click on the featured page, they only see the one post–they don’t see that they’ve just entered a full blog space. I want the featured page link to actually take them to the blog, not just the first post.

    Is there any way to make this featured page actually lead to the page, instead of to the first blog post?

    The blog I need help with is gartenwakefulness.wordpress.com.

    #3264860

    bsanevans
    Staff

    Hi @lagarten ,

    I just checked your site. The links “Book Updates” and “Movie Reviews” on your top page now takes you to a page with the list of posts, not the top post. I think this is what you were trying to achieve. Am I correct to presume you figured it out yourself? If so, congratulations!

    Feel free to let us know if you need any more assistance. Cheers!

    #3264979

    lagarten
    Member

    Thank you for taking a look! But no, I did not figure it out. The Book Updates and Movie Reviews show sub-pages in a grid format. It’s the Poetry and Quotes link that I’m worried about. I want the Poetry and Quotes link at the bottom of the landing page to lead to the blog. But whenever I try to select the blog link to show up as that featured page, the link only leads to the first post of the blog, not the full blog page itself. This is very confusing for visitors, since they will assume the one post is all there is to see.

    Right now I have a work around. The Poetry and Quotes featured link leads to a different page, and that page lists the link for the full blog. But this is not ideal. There should be a way to make the blog the featured page on the landing page.

    #3266119

    bsanevans
    Staff

    Hi @lagarten ,

    Sorry it took me a while to get back to you. And thank you for the extra information about what you would like to do.

    I’ve had a look around and found there is no simple way to achieve what you are trying to do. You are using the theme Edin. If you look at the theme info page below, at the very bottom of the box “Theme Options”, you will notice it says the following.
    https://wordpress.com/theme/edin/

    *For any of the featured pages selected for the front page, keep in mind that if you choose your posts page, the front page will display the excerpt and featured image of your latest blog post.

    So, what you are experiencing is indeed how the theme is designed to work.

    There are two workarounds I can suggest. The first one is to do exactly what you are doing – create a separate landing page that will then link to the posts page. If you are fine with keeping what you have, then there is nothing else you have to do.

    The second option is to manually add a list of posts to the landing page you have created using the Display Posts Shortcode. Are you familiar with Shortcode? I would be happy to walk you through setting this up, if you are interested. While you won’t get the exact same look as a default Posts page would give you, you could create a system that would reduce the clicks your users would have to do to get from your home page to the lists of posts.

    For example, try adding the following shortcode to your current landing page, preview it and see if this would be close to something you would want to implement. Once you’ve opened the editor on https://gartenwakefulness.wordpress.com/poetry-quotes-2/, add a new Shortcode block to the bottom of your page. then, add the following code.
    [display-posts include_content="true" include_date="true" date_format="F j, Y" wrapper="div"]

    Let me know your thoughts. All the best.

    #3277230

    lagarten
    Member

    Thank you so much! I’m sorry it took me so long to respond. A lot was going on. I just tried attaching this shortcode at the end of the HTML for my posts landing page, and I’m so excited! All the posts show up!

    However, it looks all squished together. The titles are hyperlinked, but with no formatting or extra space to show that we’ve move to a new blog post. Is there any way to modify the shortcode to make the blog posts more distinct?

    #3277260

    bsanevans
    Staff

    Hi @lagarten , no worries! We all have things come up :)

    While Shortcode is pretty nifty, the downside is there is a limit to how much you can customize the appearance of different items. If you are on a Premium plan, you have CSS customization capabilities which allows for more formatting options. Let me know if you have Premium, and I can help you with that, too. For the moment, I will make a suggestion based on the assumption you are on either the Free or Personal plans.

    The Display Posts Shortcode support page has a list of arguments you can include in your short code. Basically, this is the extent to which you can edit the appearance of your post list.

    The following shortcode is similar to what I gave you last time. Except here, the titles of the posts are listed as an unordered list and the content of the posts are not visible.

    [display-posts include_date="true" date_format="F j, Y" wrapper="ul"]

    Would that be any better for you?

    Let us know how you go!

    #3277531

    lagarten
    Member

    Thank you so much for your help! I experimented with the different shortcodes, but without being able to style them (you are right that I don’t have a premium plan), they just look too clunky compared to the rest of the site.

    Maybe when I upgrade I’ll experiment again. Thank you again for answering my question!

    #3277797

    bsanevans
    Staff

    No problem, @lagarten . All the best!

The topic ‘Cannot Set Blog as a Featured Page’ is closed to new replies.