Need help? Check out our Support site, then

Cannot upload images to blog without an an error, how can I fix this?

  1. When attempting to upload an image into a blog post I always get an error message telling me that the image file is empty and to upload a more substantial file. I have tried multiple file types and file sizes and I always get the same error message and my image does not upload. I've already cleared my browser cache and deleted the cookies from my computer. What else can I try?

    The blog I need help with is

  2. You ought to be able to upload files in two ways: by going to Media → Add New from your dashboard or by clicking the new Add Media button right above the editing area of a page or a post.

    See also

    For troubleshooting images see here >

  3. If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    If you are running one of the browsers and versions listed at please do these four things:

    1. Try clearing your browser’s cache:

    2. Make sure that you have third-party cookies enabled:

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary and also post any error reports you get.

Topic Closed

This topic has been closed to new replies.

About this Topic