Can't delete a category, using all available functions, it will not delete!!!!!!

  • Author
  • #1048377

    On my blog, A Family Affair, it shows NO categories. On the dashboard it shows ONE category. I’ve tried and tried to delete it. Using the bulk function doesn’t work. It also won’t let me delete the content through the edit function. I want to clear the whole account and start over. I’ve tried for days now, asked for help, and getting no where. I wanted to upgrade but it looks like that’s not a good idea, nor would there be any phone support. Getting very frustrated in Grass Valley. Please help.
    Blog url:

    The blog I need help with is


    WordPress requires a default category. The one that they use is Uncategorized, but you can change it to something else if you wish. I remember when I had a time trying to remove all categories, it was so frustrating until I learned this. I do not know why it is required, unless it has something to do with where to place content in their Reader if no other categories are selected.

    The reason you do not see any categories listed on your blog directly, is you have no posts, but once you start placing posts on your blog again, the categories will show up. I use a default category related to my blog content. I rarely use it, wanting to have categories more specific, but it is defaulted to that one when I forget to set a category.

    I don’t know if this helped or not. Hopefully someone else can if you need it.

    If you do chose to get a paid upgrade, they do have a help page to send concerns directly to the staff. I’ve received helpful replies from them, but depending on their load it may take a little longer than the volunteer support in the forums.


    thebirdingbunch is correct. Every post must have a default category. You cannot delete the deafult category. You can only change it. To do that you follow the instructions here > Categories cannot display in the Categories widget or on Categories pages until you actually assign the Category to a post and publish it.


    When you need help be clear about where to find it please. This link is posted in many places including on the bottom of your Admin page. is where all support documentation is found. the search box there provides results form both the support docs and from forum threads like this one.



    I believe it was the default issue. That information was helpful. It seems I have resolved all the problems. I was able to move the one blog to the business account, and deleting it from my personal account worked this time. I was able to change the content of the default category and am now creating new categories. I’m sorry about posting in the wrong places or multiple places, no idea how I’m doing that. Just following the links presented when I couldn’t find an answer. Thanks again for your help and patience. Kathy



    Hi Kathy,
    It’s good to know your issues have been sorted. Best wishes to you.

The topic ‘Can't delete a category, using all available functions, it will not delete!!!!!!’ is closed to new replies.