can't edit images inserted into post

  • Author
  • #1041469


    Used to be that after inserting an image into a post, you could go back and edit it by just highlighting the image in the editing screen, which would then give you two icons, one to delete the image and the other to edit it. By clicking on the editing icon, you got a little box with all kinds of editing choices. Now, however, when I highlight the image, I get no icon at all.
    Blog url:

    The blog I need help with is



    I am having the same problem. :-(



    I had the same problem– could edit some images, but not many. That was in Chrome. The problem doesn’t seem to exist in Firefox.



    I’m using Safari and I’m having all kinds of problems. I can’t do anything with images aside from loading. I’m not even able to delete them from a post once they are inserted. What a mess!

    Is there any word on what’s going on or what we can do to solve the problem?



    Happens to me in Safari, Firefox, and Chrome. I have not found a browser yet that allows me to edit or delete images inserted in posts. Have not heard from WordPress about any fix, either.



    (1) Did you create the post you cannot edit on the main page of here!/post/
    Or did you create the post on your own blog’s dashboard here >
    Dashboard > Posts > All Posts > Add New

    Edit post screen

    (2) Are you using the secure https:// login?

    (3) Exactly which browser and version of it are you using. If you aren’t sure click here to find out >

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    Have you done any troubleshooting? Below are the troubleshooting steps we take whenever any issues like this arise and undertaking them will provide valuable feedback information for Staff:

    a. clearing your browser cache and cookies >

    b. Using the browser with all extensions or add-ons disabled

    c. updating the browser to the latest stable version (not a buggy BETA browser version)

    d. Confirming third party cookies is enabled on the browser

    e. Confirming JavaScript is enabled

    f. Confirming Flash is updated and if required installing the latest version of Flash

    g. Resetting your router and modem and rebooting your computer
    then logging in using the secure https:// log-in

    h. Trying another browser



    The long and short of this is we need you to go through all the troubleshooting steps I posted above and provide your details.



    Did it all. Tried updated versions of three browsers on two different machines. Enabled javascript and Flash. Enabled cookies from third-party browsers and advertisers briefly on Safari and that didn’t help, so went back to blocking them. That’s always been how it’s been set up, and I’ve never had a problem. I created the post on the dashboard. I did not use the https secure long in. Timethief, before I start resetting my router and modem, can you tell me–are you able to edit and delete images inserted into posts?



    I’m finding I can edit if I leave the window for a little while and come back, but I only get one shot at it. If I try to edit again, nothing works.



    I have been searching and I notice others are also having trouble with image uploading and editing. I also found out that Staff are aware of the issue. So all I can suggest is that we all take a break while Staff sort this out.



    Just checked, and everything looks okay now. I see the little edit and delete selections when I highlight an image in edit mode. Thanks, WordPress.


    Just wanted to add it also is working for me, except for the crop feature. It allows me to frame the cropping, but doesn’t work when I push “Save”. I’m working in the latest Chrome version and have done all the above checks.
    Other than that, good job WordPress team. Thanks!



    I’m having the same issue with cropping. (I realize it’s not the exact same issue as the OP but it does fit the forum title.) When I edit an image in my Media Library, I can rotate, flip, and scale the image; but the option to crop is completely inactive. I have tried on several different images (already inserted into a post as well as freshly uploaded) and multiple browsers (Firefox, Chrome, Safari, IE9).

The topic ‘can't edit images inserted into post’ is closed to new replies.