can’t edit posts

  • Author
  • #155438


    When I try to post a new article, I can switch between Visual and Code mode.
    After publish it, if I want to modify the post, I can’t switch to Code mode and all changes under Visual mode will not save.

    Moreover, I wrote a long article, after published it, only 60% of the content show up.
    (Some sentences in the article are missing)
    And again, I still can’t modify it.
    In the end, I rewrote the whole article in a new post and published it.

    I tried two different computer and all result in the same situation.
    Please help me solve it. Thanks.



    I think this is a bug that people have noticed over the last few days. Staff were working on it yesterday but it might not be fixed yet.

    Have you tried turning off the visual editor, to see if that makes a difference? You can do that in Dashboard > Users > Your Profile. It might also be worth clearing your browser cache. And if you do write any text, copy it to something like Notepad before you hit publish; that way if it doesn’t show up, you don’t lose everything.

    If it still doesn’t work, you’ll have to send an email to staff when support opens to let them know about the problem; you’ll need to provide details of exactly what’s happening so they can help.



    Hey, I have this exact problem! Specifically, on at least one post, it simply will not accept any edits. I make the changes, click save, everything looks fine except when you check the post the edits were not made. If I click “save and continue editing” I can see it happen right there; the page refreshes, but it comes back minus the edits.

    The weird things is that it’s happening on the one post I want to edit, but tests show it is NOT happening on some other posts.

    I also noticed that in that one troublesome post, I could not go into “code view.” So I took cjwriter’s advice and turned off the visual editor in my profile, and guess what? I was able to edit the post!

    That doesn’t mean the problem is resolved. All I have is a temporary workaround.



    Would you like to post a link to your blog and to the post in question so staff can locate it when they work on this?



    I have a similar problem. When writing in my post, the editor won’t give me the toolbars for either visual or code. I have looked all through the site and now the forum but no help yet. Could someone help me out? It’s probably some button I need to push and I’m just not seeing it.



    Check in Dashboard > Users > Profile that the “use the visual rich editor when writing” is checked. It can get turned off by accident. If it isn’t that, try clearing your browser’s cache and try again. If that doesn’t work, what browser are you using? If you have another one try it in that, something like Firefox if you use IE or Safari.

The topic ‘can’t edit posts’ is closed to new replies.