Need help? Check out our Support site, then

Can't embed videos from YouTube - only get the URL displayed in the page

  1. Hi, I can't seem to embed videos from YouTube in multiple .com blogs anymore. I have tried pasting in the direct URL for the video, the YouTube short code, the WP [youtube=URL] version and all three just give me the link to the video in the blog post (link is not clickable either). This was working fine for many years, but perhaps is an issue today or recently?

    I've tried clearing cache, etc. and putting a YT url into a new post seems to be an issue. Any thoughts or any known issue with this?

    Blog url:

  2. There is no known issue with using the youtube shortcode. Note: you cannot use this code for "channels" it's only for individual videos. If you post the youtube link here and I will provide the shortcode for you.

  3. enjoyingthejourneys

    I am having the same issue.

  4. If you post the youtube link here and I will provide the shortcode for you.

  5. enjoyingthejourneys

    Thanks for your reply. It worked for me after following the link you included above. I appreciate your support. ~ Kristi

  6. That's good to hear. Best wishes for trouble-free blogging. :)

  7. Thanks for the reply, timethief. I am finding the embedding of YT videos to be inconsistent. On one blog it works if I simply add the direct YT link on a line by itself, without using the shortcode. In another blog, that method does not work, but the shortcode does. I tried the shortcode again on the site where it did not work yesterday and it is working today. Go figure.

  8. I always use the shortcode and it always works for me. I'm glad to hear it worked for you too. :) Will you be kind enough to enter the top of this thread and mark it "resolved" please?

  9. I think the point isn't that the YT shortcode works for you every time. I did try that yesterday as I mentioned in my original post and it did not work for me. Considering that many people have been reporting issues adding YT videos to their posts over the last few months, I do suspect something is going on behind the scenes that is causing the inconsistent behavior. Works for now with shortcode so that is fine.

Topic Closed

This topic has been closed to new replies.

About this Topic