Can’t embed youtube video anymore

  • Author
    Posts
  • #562879

    conceptpt
    Member

    Unfortunately, anytime i attempt to embed a video or playlist from youtube, wordpress will not allow me to do so where the player is on my page. The only option working for me now is to use the youtube link which directs my traffic to youtube. That’s cool and all but defeats the purpose of having a wordpress blog. If i wanted to my traffic at youtube i woould just use my youtube acct only. I tried the support examples but keep coming up with the same result. I am sure this is user error. Someone please help.

    The blog I need help with is weaponsofinfluence.wordpress.com.

    #562974

    conceptpt
    Member

    So, i’ve realized i can embed video but not youtube playlist. any help?

    #562975

    conceptpt
    Member

    the following is the result i am getting just showing the embed code as opposed to playlist player.

    <object width=”480″ height=”385″><param name=”movie” value=”http://www.youtube.com/p/0272126BE08532B6?hl=en_US&fs=1″></param><param name=”allowFullScreen” value=”true”></param><param name=”allowscriptaccess” value=”always”></param><embed src=”http://www.youtube.com/p/0272126BE08532B6?hl=en_US&fs=1″ type=”application/x-shockwave-flash” width=”480″ height=”385″ allowscriptaccess=”always” allowfullscreen=”true”></embed></object>

    #562984

    timethief
    Member

    Are you using these insructions or not? http://en.support.wordpress.com/videos/youtube/

    #562994

    conceptpt
    Member

    yes, and i keep just ending up with the embed code showing in the post. only for a playlist though, which used to work. just figure i’m doing something wrong.

    #562995

    conceptpt
    Member

    when using the embed code i get the result above. if i use the option as described in the instructions: i end up with only a link directing my traffic to youtube. didn’t know if i was being confusing with my statements as i am trying to achieve the same result with two different methods.

    1: embed code =

    <object width=”480″ height=”385″><param name=”movie” value=”http://www.youtube.com/p/0272126BE08532B6?hl=en_US&fs=1″></param><param name=”allowFullScreen” value=”true”></param><param name=”allowscriptaccess” value=”always”></param><embed src=”http://www.youtube.com/p/0272126BE08532B6?hl=en_US&fs=1″ type=”application/x-shockwave-flash” width=”480″ height=”385″ allowscriptaccess=”always” allowfullscreen=”true”></embed></object>

    2: shortlink option =

    only a link to view on youtube, not in my wordpress site.

    #563023

    ironvan
    Member

    I am having the same problem. Little help anyone?

    #563025

    disembedded
    Member

    [YouTube=http://www.youtube.com/p/0272126BE08532B6&w=480&h=365&rel=0]

    #563030

    macmanx
    Staff

    As long as you’re following the “quick embed” or shortcode methods outlined at http://en.support.wordpress.com/videos/youtube/ you shouldn’t have any problems.

    Do not use the embed code provided by YouTube.

    If you continue to have problems, please link us to a post displaying the issue.

    #563368

    I am having the same issue on my non wordpress.com wordpress server. See here:

    http://67.23.43.198/

    I have entered the quick embed code as you stated in your documentation, yet it fails to transition it to a youtube embed. Is this because I am using the free downloadable installed version of WordPress?

    #563369

    airodyssey
    Member

    @bigtimeweenfan: If you have a self-hosted WordPress.ORG blog, you are in the wrong forum. Please ask your question on http://wordpress.org/support

    You are currently in a WordPress.COM forum and our answers will not apply to your situation. Thanks and I hope you find a solution to your problem soon.

    #563381

    mmmmpizza
    Member

    I had the same problem only recently. I just got it to work by using the embed code that youtube gives. When you paste the code into the post and publish wordpress reorganized it. It removes the = that was in previous instructions. I then deleted the dimensions or you can change the dimensions for the width of your blog.

    Youtube gave me this:

    <iframe title=”YouTube video player” width=”640″ height=”390″ src=”http://www.youtube.com/embed/vVFasyCvEOg” frameborder=”0″ allowfullscreen></iframe>

    when you publish wordpress reorganizes to this:

    [youtube http://www.youtube.com/watch?v=vVFasyCvEOg&w=640&h=390%5D

    change the height / width to fit your blog or delete

    #563382

    mmmmpizza
    Member

    the end bracket did not publish above? The link hould end in 390]

    #563383

    airodyssey
    Member
    #563392

    It looks like there’s a new youtube “share” URL beginning http://youtu.be/…. I’m having the same problem.

    #563393

    raincoaster
    Member

    Yes, don’t use that shortcode. It doesn’t work anywhere but Twitter, I’ve no idea why they introduced it.

    Look at the URL bar in the browser when you’re on the video’s page on YouTube. It’ll be something like:

    What you use is all the URL up to but NOT including the &. Drop it and everything after it, and use that code, the

    in the standard shortcode format of [youtube=http://www.youtube.com/watch?v=BMsKHKqUydM] and make sure the link isn’t “live” ie underlined and active. Use the Link Breaker icon to make sure it’s not active.

    #563394

    Thanks, raincoaster :)

    #563408

    noblechurch
    Member

    Please help me embed a YouTube playlist:

    http://wp.me/PbgJt-4K

    I am able to embed a single video but cannot figure out a playlist.

    Thanks for your help.

    #563409

    timethief
    Member
    #563410

    noblechurch
    Member

    Thank you,

The topic ‘Can’t embed youtube video anymore’ is closed to new replies.