Can't Get Custom Fonts To Work

  • Author
    Posts
  • #1864132

    Hi,

    I have done some pretty hefty customisation of the ‘Sandbox’ theme (which has involved much weeping and gnashing of teeth!) – I’m finally there now but am having problems getting custom fonts to show up.

    I’ve paid for the Custom Design upgrade (obviously), but when I apply certain fonts they show up in the preview but not in the blog. I know a bit about CSS but am far from an expert and find it a bit of a ‘black art’ a lot of the time.

    A few questions…

    Can I only use the fonts I’ve selected using the ‘font’ menu (so two custom fonts per blog) or should I be able to access the other typekit fonts using CSS?

    What is the exact syntax for importing a font via CSS – I’ve tried the usual stuff but some of it seems to be getting stripped out?

    Are there any other fonts available other than the ones that come up on the popup list (which is a pretty limited selection)?

    The two fonts I want to use but can’t get to work are Ubuntu and Meta. I seem to have ‘Chunk’ showing up OK.

    Thanks in advance for any help.

    The blog I need help with is bitbulldotcom.wordpress.com.

    #1864426

    Hi, currently there are only two fonts that can be selected at a time, or set at Appearance > Customize > Fonts. If you previously had an Typekit ID (account) linked to your site here, you can continue to use the Advanced Mode, which would allow you to specify more than two fonts. If you did not have a Typekit ID associated with your site, or if you previously disabled Advanced more, you would not be able to reconnect it.

    #1864462

    Are there any other fonts available other than the ones that come up on the popup list (which is a pretty limited selection)?

    Not at this time, but we’re hoping to add more options in the future! I know that doesn’t help you in the short term, and I’m sorry about that.

    I checked out http://bitbulldotcom.wordpress.com/ and it looks really fantastic! It’s an incredible customization example of the Sandbox theme.

    What is the exact syntax for importing a font via CSS – I’ve tried the usual stuff but some of it seems to be getting stripped out?

    You probably had the right syntax, however, importing fonts is not permitted at WordPress.com for security reasons (all of the font sources would need to be whitelisted and we would need to trust the source completely—making a decision and a change like that from the current setup we have in place takes time).

    The two fonts I want to use but can’t get to work are Ubuntu and Meta. I seem to have ‘Chunk’ showing up OK.

    So, if you only have two fonts available to use at a time, will that work out okay for you for now? I’m hoping yes as I really like what you’ve done with your site. :)

The topic ‘Can't Get Custom Fonts To Work’ is closed to new replies.