Can’t get custom header working…

  • Author
    Posts
  • #408818

    I’m using the “Painter 1.1” theme, and am trying to upload a custom header. I select my image and click upload, but it keeps coming back with the following:

    Unable to create directory /var/virtual/web/w1788/html/blog/wp-content/uploads/2009/10. Is its parent directory writable by the server?

    The blog is going through another domain name (domain.com.au/blog) – perhaps I need to do something with my FTP settings?

    Any help is much appreciated!

    #408964

    supportbot
    Member

    You did not specify a blog address or reason for posting when you created this topic.

    This support forum is for blogs hosted at WordPress.com. If your question is about a self-hosted WordPress blog then you’ll find help at the WordPress.org forums.

    If you don’t understand the difference between WordPress.com and WordPress.org, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It’ll help people to answer your question.

    This is an automated message.

    #408967

    wpadvanced
    Member

    You need to chmod the directory /wp-content/ to 777.

    Anyways, you’re in the wrong forum.
    Next time, head on over to WordPress.org.

    #408982

    chmodding the wp-content directory to 777? I can’t tell you how bad an idea that is.

    #408983

    timethief
    Member

    Oi Vey!

    #408984

    raincoaster
    Member

    I can’t either. Because I have no idea what it means.

    #408988

    chmod 777 is a permissions setting for a folder or directory and it basically opens the folder up to the entire planet – probably even the universe.

    It is so way bad I can’t even find the words.

    #409004

    wpadvanced
    Member

    Yes, that’s why you create the correct directory and chmod it back. I think 766 is ideal.

    Some from the codex:

    766 means that the directory is readable and writable by WordPress and any and all other users on your system. If 766 doesn’t work, you can try 777, which makes all files and folders readable, writable, and executable by all users, groups, and processes.

    Some plugins require the /wp-content/ folder be made writeable. In some cases, this may require assigning 755 permissions or higher (e.g. 777 on some hosts).

    #409007

    For directories, 755 is the maximum. 644 is the maximum you should set files to.

    If a plugin requires wp-content to be set at 777, the plugin is shit and should not be used. No half-way competent plugin designer would build a plugin that required that.

The topic ‘Can’t get custom header working…’ is closed to new replies.