Need help? Check out our Support site, then

Can't get into my account. Frustration

  1. I have tried everything to get into my site to no avail. This is really frustrating and don't know what to do. Hope someone can be of help. Below is the reply that I get every time I want to get in.

    Cannot Access the Dashboard Requested

    You are logged in as "ecaparis" and do not not have the necessary privileges to access the dashboard for "". If you are not "ecaparis", please log out, and log back in with your username. If you are "ecaparis" and you need access, please ask an administrator of the site to invite you.

  2. It sounds like you are trying to log into the dashboard for instead of the dashboard for your blog.

    This should be a direct link to your dashboard (replace "blogname" in the following link.

  3. I've been getting the same message, that I'm already logged in. I checked by going direct to my web page, not logged in; then logged in and got the message quoted by ecaparis.

    I recognise the the log-in link given by the sacredpath, but my own shortcut has been changed to

    I'll change it back, but it's puzzling how it got changed.

  4. Sacredpath, this is the same problem I am having and wrote about a few days ago under another subject. I have always gotten to the login page by typing I just wonder why something like that would change with no kind of explanation. Doesn't https rather than http make your login more secure?

  5. I forgot to check that I want to be notified by e-mail of any responses.

  6. Yes. I'm having a similar situation. Using the bookmark I've always used and which has been fine now tells me I can't login, even though when I type in my username it autocompletes it. I then have a list of my blogs, apart from my main one, but there is an unlabelled 'dashboard' link at the top of the list which I can click and get in okay.

    But something's not quite right.

  7. Beause the security of my site is uppermost in my mind, when I get a weird error messag like what we have been getting, I do not feel comfortable clicking anything except I did just click logout.

    I can get to my dashboard doing what Sacredpath said. I did https not http and it worked. Is that the correct and safe solution, Sacredpath or anyone else who knows?

  8. I got this today for two separate accounts, though the links to the blogs below it worked okay. I log in on and always have done (for over two years) with no problem til just today. Does anyone know yet why this has been changed?

    @thesacredpath (or anyone else who knows) - can one log in on the blog's name using https or does it not recognise that?

    Thanks for any help.

  9. Can you please verify the URLs of the blog's you're trying to access?

  10. gigiassounwarne

    Ok guys, I sorted it out. I had to log in from the website not from the dash board...Thanks to all for your help.

  11. lindalou10, try accessing your Dashboard at

  12. Thank you, macmanx. I appreciate your response. I'm logging in that way and all is well.

  13. You're welcome!

  14. I do have another question about this same situation for macmanx or someone else who knows will respond. So now when I go to why does it show that I have been redirected to the page where I get to log in? I am uncomfortable with redirects. How do I know what is going on and when such a redirect is safe?

  15. https is a secure login, but it has to redirect from the unsecure page TO that secure page! The default login page is http not https.

    You'll only be able to use https here if you adjust your settings. See this:

  16. I haven't understood any of the above and for the past few days am being greeted by the intervention discussed here: "User ontheliner Cannot Access the Dashboard Requested etc" and that I lack the "necessary privileges to access the dashboard".

    I'm doing nothing different. Simply trying to log in to my blog from the same bookmark on my browser that I've been using for years. Has something changed?

  17. My settings have always been set to sign in to https and they still are set this way. So what absurdoldbird said about the redirect is not true in my case. So I am still asking the question as I asked above: "Why the redirect at the login?" Is there something more going on that could possibly affect the safety of our content or privacy or something like that? I would like to add another blog to my account at this point but I just don't want any trouble. I really would like to know that this login drama is not taking something away from us--the bloggers.

  18. I'm doing nothing different. Simply trying to log in to my blog from the same bookmark on my browser that I've been using for years. Has something changed?

    Staff is upgrading the WordPress software we run on and has also been moving all of our most active pages like Stats, Reader, Topics, Freshly Pressed, etc. to the fron page of Perhaps those changes have had an effect on your ability to log-in. I suggest trying to log-in directly to your blog by using this link

  19. Excellent, timethief - worked first time, thanks.

  20. Alleluia! I love happy endings. :)

  21. lindalou10, I'm not entirely sure what you're referring to, as logging in at will send you to

    You might be referring to the operation of our login system.

    When you log in at your information is sent through our secure login system, then you're sent back to

  22. Macmanx. Thank you. I think I'm done asking questions about this now. Bottom line, I just need to have a little more faith! Thank you for all your help. And I like your style.

  23. You're welcome!

  24. Hello!
    I hope someone can help me. I have spent a frustrating day with my hosts trying to get access to my blog.

    It is

    I have used to login.

    When I log in my details it takes me to
    but the page remains blank!

    Can anyone help please?


  25. @jfb57
    You are posting to thw rong support forum and we cannot help you here with that site. It's not a free hosted blog. You must post to Please read this for clarity >

Topic Closed

This topic has been closed to new replies.

About this Topic