can’t get to my blog

  • Author
  • #262128


    I can log in. I can see my dashboard. But, when I click on “Visit Site” my site won’t come up. I’ve tried several times over the last 2 hours. Any ideas? Anyone else having this problem?




    I am having the exact same issues… I can see my site if I log out of WordPress… but if I’m singed in and using my Dashboard, it’s a no go…



    Yes, I had forgottne to mention that I am able to get to my blog site if I am not logged in. It’s strangely comforting to know I am not the only one, but I wonder what’s going on.



    i can’t get to my blog either way…

    i can log in and see my dashboard, but if i try to view my blog, it just tries to load and load and load – i can hear multiple “clicks” like the page loading, but it never does.

    i also tried going direct to my site without logging into wordpress, but the same thing happens, lots of clicks and nothing comes up.

    i’ve been trying to view mine for about 4 hours, i made & published a post and wanted to view it, but so far nadda.

    — but it is good to know that maybe it’s a site issue and not a problem with my blog!



    teeveebee – I can get to your site. caflynn – what is your blog?

    I’m thinking there has to be a server glitch since others have reported the same thing I think you should report it to support.



    Yes, tamisanders, it is happening the same for me. I can tell my computer is thinking and trying and trying to load, but it nothing.

    Thanks, Vivian. I will report it to support.



    I can’t get to either of my blogs – what’s up? I can get to my dashboard by going to the WordPress website, but cannot get my own site….



    Same thing on my blog at using IE7. At least one other user on the blog is able to access it just fine, but not me. Problem only occurs when I am logged into WordPress. If I log out, I can get the main page without any issues.

    Just for posterity, a detailed description: the IE7 browser is redirecting me to It tries to refresh a lot of times, then gives me an error that says “Invalid key.” I tried deleting cookies and temporary internet files, but no love if I log back in. Also, it works okay in Firefox whether I’m logged in or not. I have another blog, and I’m able to get to it without any problems when logged in on IE7.

    Probably a server glitch or something.


    I’m having issues as well, and suspect staff is doing something in the back alley, or there are server or internet networking issues.



    Well, if you look at the blogs of everyone who has posted in this thread and the other one, wgat we all have in common is that our blogs are all registered to our own domains. For example, my website is, not My other blog ( has the “wordpress” in the domain name, and I can get to it just fine. So I think it has something to do with a DNS service or something.



    This was probably caused by a brief bug that was fixed about 2 hours ago. If problems persist, please start a new thread or contact support.

The topic ‘can’t get to my blog’ is closed to new replies.