Need help? Check out our Support site, then

Can't get YouTube video to embed

  1. I can't get videos from YouTube to embed properly. I was using the "add media" button, and that worked as recently as five days ago. I've been trying to do an embed since then, and nothing works. The "add media from URL" just gives me a hyperlink. I've tried pasting the link straight into the post, as the help threads suggested, but that just gives a hyperlink, too. I tried using the shortcode, as some of the help suggested, and that displays as an empty post with no title. Any ideas?
    Blog url:

  2. I have zero difficulty when I use the youtube shortcode. I suggest that you try it again.
    [youtube] embeds a YouTube video. ยป Full instructions

    This is the youtube link >
    This is the shortcode:

    That code is shortcode correct as it's now operating in my test blog.

  3. I've tried shortcode a couple of times and it's still not working.

  4. Did you change anything at all in the shortcode I posted above? I'm asking because I posted this to my test blog yesterday and it's working fine. I just posted it a second time minutes ago and it's working too.

  5. michelleegreco

    I had a problem like this a few months ago. Copy the code from the "embed" option on Youtube. Make sure to paste this code under the "HTML" tab of your post, not the "Visual" tab. I was embedding in the wrong tab. I hope this helps!

  6. I have used the shortcode in both the visual editor and the HTML editor and I was successful posting this video using both of them.

  7. It worked this time, as I copied and pasted what you put up. However, I had manually typed the shortcode in previously, and copied and pasted the address, adding the youtube= and the brackets by hand, and it didn't work then.

  8. OK, for some reason I wasn't seeing the part about doing it under the HTML tag. I've been trying to embed another video, and when I did it that way, it worked perfectly. Thanks!

  9. Awesome, glad it worked for you!

  10. I too always embed in the HTML tab using the shortcode. In theory it should not matter and the wordpress software should pick it up in the visual editor as well, but in my experience that happens only about half the time. If you do it in the HTML tab it always seems to take the first time.

  11. Usually the reason the shortcode fails is that the link is pasted in "Live" ie blue and clickable. Just put the cursor on it and hit the Unlink icon, and it works.

  12. I just tried raincoaster's suggestion and am waiting a few minutes for the results. I have an unrelated problem where any change that I make to one of my posts seems to need a few minutes to go live on my site.

    I tired what I thought was obvious which was clearing my site cache, clearing my browser cache, and even going to another browser or another computer entirely ... But alas, I just live with it.

Topic Closed

This topic has been closed to new replies.

About this Topic