Can't hide related posts

  • Author
    Posts
  • #2252561

    mgoodwin
    Member

    I’ve specified “Hide related content after posts” on the site Settings page, but supposedly related content is displayed after the posts anyway. The problem is that our organization has annual events, and the “related” posts are often from previous year and are not relevant at all. This confuses people because they click the “related” posts and don’t bother to check the date, and they think these posts are about the current year’s event.

    Since I’ve already selected the “Hide related content after posts” setting, how do I get it to actually not display these?

    The blog I need help with is jocogop.org.

    #2252646

    timethief
    Member

    The related posts feature works on almost all themes hosted by WordPress.com. For themes that already have a built-in related feature (Expound, Traveler, Opti, and Currents), the feature is disabled.

    You are using a very old retired theme called Vigilance. Themes are retired when they no longer support all WordPress.COM features. Perhaps that’s the cause of your issue. I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond. To subscribe look in the sidebar of this thread, find the subscribe to topics link and click it.

    #2252654

    mgoodwin
    Member

    Thank you!

    #2252657

    timethief
    Member

    You’re welcome.

    #2252796

    amightywp
    Member

    Hi there,

    I just took a look at your site and it looks like you’ve gotten the “related content” issue sorted out. I didn’t see related content included on any of your posts.

    Did you have any other issues?

    #2252800

    roguevideo
    Member

    Timethief mentioned that I was using an older theme that doesn’t support many of the current features, so I updated my site to one of the new themes and that solved the problem.

    Thank you!

    #2252804

    amightywp
    Member

    That’s what I figured had happened, but I didn’t want to assume . . . as soon as I do it usually turns out that I missed something! ;)

    Thanks for letting me know though.

The topic ‘Can't hide related posts’ is closed to new replies.