Need help? Check out our Support site, then

Can't import to blog from Moveabletype OR blogger formats

  1. I'm new to wordpress but a reasonably technical user. I've tried several times to import my blog in movabletype format into No luck. I also have a dump of the blog in blogger format. I tried that, and no luck.

    I should say that I get a dialog asking about userID mapping (seems good) and an email saying "it worked" but no posts appear.

    I'd like to use this service, and would pay for some of the upgrades, but only if I can import my content. Any suggestions? Is help available? Thanks!


    The blog I need help with is

  2. Hi there,
    I flagged this thread for Staff assistance with your import. Please be patient while waiting.

  3. Did the Movable Type export file have a .txt extension?

  4. macmanx: Yes, the movabletype export file does have a .txt extension.

  5. Guessing the next step, I tried importing the same file to a test blog without using a .txt extension, but no luck. FWIW, the export file comes from an installation of roller at my work, but purports to be in moveabletype format. I checked the spec on the moveabletype website and the file looks conformant.

    The entries look like:

    <br /> --------<br /> AUTHOR: user12618941<br /> TITLE: Tiny Robot, Nice Lens<br /> DATE: 06/02/2008 00:58:33<br /> PRIMARY CATEGORY: Miscellaneous<br /> STATUS: publish<br /> ALLOW COMMENTS: 1<br /> -----<br /> BODY:<br /> <p>Here's a toy I picked up recently<br /> ...<br />

  6. Hm, that could be the problem.

    Do you have access to a Movable Type blog to import that into?

    If so, try importing it there first, then export it from Movable Type.

  7. macmanx: this was a good idea. I installed movabletype, set up my blog there; it was able to import my blog entries but the bodies were missing. So using that as a clue, I was able to iterate to discover the problem. The export file from my old blog had:

    "BODY: " (that's BODY, a colon, and a space)

    Whereas moveabletype's output is:

    "BODY:" (that's BODY, a colon, and no space).

    Apparently that is enough to confuse both movabletype and wordpress. But at least movabletype was able to import the headers, which was key to narrowing down the issue.

    I will say that the import process is pretty painful-- some debugging output would really help. But thanks for giving me a clue in the right direction.

  8. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic