Need help? Check out our Support site, then

Can't log into my account

  1. When I try to log into my this is the message that shows up:
    Fatal error: Cannot redeclare get_post_to_edit() (previously declared in D:hosting10115597htmlwp-adminincludespost.php:473) in D:hosting10115597htmlwp-adminincludesdeprecated.php on line 993

    The blog I need help with is

  2. I saw this same issue after upgrading to WordPress 3.5 on a blog we're developing right now (not yet in production). Oddly, we had another copy of the same blog hosted on the same server which we upgraded to 3.5 first, and it worked fine. I compared the file contents of the two blogs and they were identical, yet one reported this php error:

    PHP Fatal error: Cannot redeclare get_post_to_edit() (previously declared in <blogroot>\wp-admin\includes\post.php:473) in <blogroot>\wp-admin\includes\deprecated.php on line 993)<br />

    This made me suspicious of state, so I reset the IIS server that was hosting both blogs, and the problem went away. This makes me suspect that perhaps some old php content was cached (which I have seen before in IIS and is maddening to diagnose). This theory is further supported by the fact that line 473 of post.php (as listed in the php error) is in the middle of a comment block -- it's not a function declaration. It looks like the get_post_to_edit() function was deprecated in the 3.5 release and moved to the deprecated.php file, but the cached copy of the old post.php still had it declared.

    Not sure if you have access to your IIS server, but if you do, running "iisreset" (from a Run As Administrator command prompt) should fix the problem. I'm also interested to hear from others hosting wordpress on IIS (not my choice) and how you deal with this php caching issue.


  3. @megan677

    Those sites are mot free hosted blogs. WordPress.COM and WordPress.ORG are completely separate and here we provide support only to free hosted WordPress.COM bloggers.

    This is the correct forum for your software http://wordpress.ORG/support/ If you have not registered a username account yet you can do so on the top right hand corner of the page I just linked to so you can post to those support forums. vs The Differences
    Best wishes with your site.

  4. oops! "mot " was meant to be "not"

  5. Yes -- I replied to this topic knowing it was rather than, simply b/c this was the only google hit for a problem I ran into and I wanted to leave a breadcrumb for others who found their way to the same page. (I actually had to reset my password b/c I hadn't been here in so long).

    @megan677, if you repost your question on, I'd be happy to reply again with what I found.

  6. @jptsetme
    I tagged this thread so Staff will be aware of your report.

  7. Please open a new thread at and post the link of that thread in this thread :)


  8. Awesome, thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic