Need help? Check out our Support site, then

Can't make initial connection to

  1. Unable to make initial connection to to activate plugin features. Error is: 500 Internal Server Error. Only other plug in is Akismet. Have loaded copy of WordPress code to another host (1and1) and verified that it works and will connect to as it should. (I'm using a modified version of Twenty Eleven and have tested with vanilla Twenty Ten as well).

    Is there additional information I can give to hosting company? (Megaservers/Web Prodigy)

    Thank you very much, Paul

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Blog url:

  2. Could you try and disable all other plugins and reactivate Jetpack. This way we can see if other plugins interfere with Jetpack.

    Also make sure you are running the latest WordPress and Jetpack version:

    Looking forward to your reply.

  3. Hi,
    Yes, have tried with and without Akismet. Same result, unable to connect.
    I am running WP 3.4.2 and Jetpack 2.0.
    This is a priority matter for me, but unfortunately your reply was sent to my junk mail folder - I will adjust my email filter.
    Thanks. Paul

  4. This problem is high likely a PHP fatal error. Could you please contact your hosting provider and ask if they blocking certain connections, and what PHP version they are running?

    Sorry for the inconvenience.

  5. phpinfo tells me that it is 5.2.9.
    What kind of connections could they be blocking? The more specific I can be with them the better. Is there anything else that phpinfo (or another call) can tell us? Paul

  6. [removed server info]

  7. PHP version seems right. Could you ask to check their PHP error log around the time that you try to connect Jetpack. (The PHP error log would be dependent on the host, and this would be the most useful thing to help us find the issue.)

  8. I have a bad feeling about the PHP error log, as phpinfo returns (in part): log_errors Off

    There is a lot of info from phpinfo(), could I perhaps send that to you as a starting point? Especially if they aren't logging errors. Thanks.

  9. I recommend contacting your hosting provider as they are responsible for your PHP settings and installation. Therefore they can also check the logs to see if there are any oddities. Perhaps there are more users on their servers that have a similar issue.

  10. I'll give it another try.

  11. Still in process, they have submitted a support ticket. Will advise.

  12. They reply "please be informed that we do not collect PHP error logs, you can also enable debug in your wp-config."

    I have attempted to enable debug using the following from word press documentation, but I find that the debug.log size remains at 0 bytes. (So I am suspicious that something is incorrectly configured.)

    * This will log all errors notices and warnings to a file called debug.log in
    * wp-content only when WP_DEBUG is true. if Apache does not have write permission,
    * you may need to create the file first and set the appropriate permissions (i.e. use 666).

    define('WP_DEBUG', true); // false
    if (WP_DEBUG) {
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);
    define('SCRIPT_DEBUG', true);

  13. Can you please try installing the Jetpack Compatibility Plugin so we can see some additional information from your site?

    1) Download the plugin from
    2) Upload the plugin to your site via Dashboard -> Plugins -> Add New.
    3) Activate the plugin and go to Plugins -> Jetpack Compatibility Test.
    4) Click the "Select All" button.
    5) Send the results of the test back in a reply.

  14. Yes, I failed to mention in this thread that I tried the compatibility test already and it fails in an identical fashion (just reverified.)

    I now suspect that perhaps it is trying to write a file and failing? Maybe? Please see my earlier comment about trying unsuccessfully to enable debug.

    Thanks for all for your assistance, I appreciate it greatly. Paul

  15. Any further suggestions for investigation? Thanks.

  16. Could you please check if the debug.log file has the proper (write) permission rights? Please make sure you set the permissions to 666, 777 or check all 'write' checkboxes when viewing the file's properties.

  17. Yes, when I created the file I set it to 666.

  18. Could you make it 777, just to be sure? you can also (temporarily) enable the WP_DEBUG_DISPLAY to see if it's working properly.

  19. Set to 777
    I set WP_DEBUG_DISPLAY to true (but did not change @ini_set('display_errors',0); ).
    I still don't see anything in the file (size 0).
    The full path to the directory is /public/blog/wp-content, I'm concerned that this needs to be set somewhere but perhaps isn't. (Otherwise blog site seems to work fine.)

  20. Could you try and set display_errors to 1? Also make sure to download the debug.log file and open the file in a text editor to see if it contains text.

  21. I checked the debug.log today and found it had some data, but only related to akismet. (was set to 777). Today I also set to "1": @ini_set('display_errors',1);

    Full data from debug.log:

    [22-Nov-2012 00:06:38] PHP Notice: Undefined index: HTTP_REFERER in /services10/webpages/s/p/ on line 323

    [22-Nov-2012 00:06:41] PHP Warning: Cannot modify header information - headers already sent by (output started at /services10/webpages/s/p/ in /services10/webpages/s/p/ on line 20


  22. I also downloaded jetpack 2.0.2, does not resolve issue.

  23. Hi there, sorry this is still giving you trouble.

    Could you please confirm that your Site URL and WordPress URL are both set to - exactly that, with no trailing slash - under Settings > General?

  24. Hi. Yes that is exactly how they are set. Thank you for following up.

  25. When you say that you couldn't run the compatibility test because "it fails in an identical fashion" could you please let me know exactly what that means? Are you able to activate the compatibility plugin alright? Do you see an Internal Server Error at some point during the test, and exactly when does that happen?

  26. I am able to activate the compatibility test, that causes no error.
    On clicking "Jetpack Compatibility TEST" (left navigation), the page goes blank (loads and the page display is:
    (Title:) 500 Internal Server Error
    (Page content:) Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, or webmaster and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    I never see anything that would allow me to perform the compatibility test itself (configure parameters, start, etc.)

  27. Could you please test whether you're are able to run another plugin? Would you mind trying to install and activate any other plugin of your choice and let me know if you get it working.

    So far, no plugins have run without some sort of error, is that right? Jetpack won't connect, the compatibility test doesn't work, and Akismet shows errors in your log. If you aren't able to successfully run any plugins on the site, it seems likely there's a configuration issue on your server, which your host would be best placed to diagnose.

  28. Akismet does show those two lines, but functions correctly. I have a couple of other plugins I can try.

    Is there possibly a debug version of the compatibility test plug in, or could we include a BREAK in it for diagnosis?

    I'll report back after I try another plug in.

  29. I am able to successfully install and activate these two plugins:

    Facebook (official) 1.1.5 (current version)
    Twitter Widget Pro 2.4.1 (current version)

    The appear to function correctly, that is, I can access their configuration pages.

  30. Thanks for testing this. I've brought this to our developer team for further investigation and will keep you posted.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.