Can't make initial connection to WordPress.com?

  • Author
    Posts
  • #1067700

    verycunning
    Member

    Unable to make initial connection to WordPress.com to activate plugin features. Error is: 500 Internal Server Error. Only other plug in is Akismet. Have loaded copy of WordPress code to another host (1and1) and verified that it works and will connect to WordPress.com as it should. (I’m using a modified version of Twenty Eleven and have tested with vanilla Twenty Ten as well).

    Is there additional information I can give to hosting company? (Megaservers/Web Prodigy)

    Thank you very much, Paul

    ———–
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Blog url: http://www.sportsactivitymd.com/blog/

    #1067900

    kardotim
    Member

    Could you try and disable all other plugins and reactivate Jetpack. This way we can see if other plugins interfere with Jetpack.

    Also make sure you are running the latest WordPress and Jetpack version:
    http://www.wordpress.org
    http://www.jetpack.me

    Looking forward to your reply.

    #1067919

    verycunning
    Member

    Hi,
    Yes, have tried with and without Akismet. Same result, unable to connect.
    I am running WP 3.4.2 and Jetpack 2.0.
    This is a priority matter for me, but unfortunately your reply was sent to my junk mail folder – I will adjust my email filter.
    Thanks. Paul

    #1067920

    kardotim
    Member

    This problem is high likely a PHP fatal error. Could you please contact your hosting provider and ask if they blocking certain connections, and what PHP version they are running?

    Sorry for the inconvenience.

    #1067921

    verycunning
    Member

    phpinfo tells me that it is 5.2.9.
    What kind of connections could they be blocking? The more specific I can be with them the better. Is there anything else that phpinfo (or another call) can tell us? Paul

    #1067922

    verycunning
    Member

    [removed server info]

    #1067923

    kardotim
    Member

    PHP version seems right. Could you ask to check their PHP error log around the time that you try to connect Jetpack. (The PHP error log would be dependent on the host, and this would be the most useful thing to help us find the issue.)

    #1067924

    verycunning
    Member

    I have a bad feeling about the PHP error log, as phpinfo returns (in part): log_errors Off

    There is a lot of info from phpinfo(), could I perhaps send that to you as a starting point? Especially if they aren’t logging errors. Thanks.

    #1067925

    kardotim
    Member

    I recommend contacting your hosting provider as they are responsible for your PHP settings and installation. Therefore they can also check the logs to see if there are any oddities. Perhaps there are more users on their servers that have a similar issue.

    #1067926

    verycunning
    Member

    I’ll give it another try.

    #1067928

    verycunning
    Member

    Still in process, they have submitted a support ticket. Will advise.

    #1067929

    verycunning
    Member

    They reply “please be informed that we do not collect PHP error logs, you can also enable debug in your wp-config.”

    I have attempted to enable debug using the following from word press documentation, but I find that the debug.log size remains at 0 bytes. (So I am suspicious that something is incorrectly configured.)

    /**
    * This will log all errors notices and warnings to a file called debug.log in
    * wp-content only when WP_DEBUG is true. if Apache does not have write permission,
    * you may need to create the file first and set the appropriate permissions (i.e. use 666).
    */

    define(‘WP_DEBUG’, true); // false
    if (WP_DEBUG) {
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, false);
    define(‘SCRIPT_DEBUG’, true);
    @ini_set(‘display_errors’,0);
    }

    #1067930

    kardotim
    Member

    Can you please try installing the Jetpack Compatibility Plugin so we can see some additional information from your site?

    1) Download the plugin from http://plugins.svn.wordpress.org/jetpack/branches/jetpack-compatibility-test.zip
    2) Upload the plugin to your site via Dashboard -> Plugins -> Add New.
    3) Activate the plugin and go to Plugins -> Jetpack Compatibility Test.
    4) Click the “Select All” button.
    5) Send the results of the test back in a reply.

    #1067931

    verycunning
    Member

    Yes, I failed to mention in this thread that I tried the compatibility test already and it fails in an identical fashion (just reverified.)

    I now suspect that perhaps it is trying to write a file and failing? Maybe? Please see my earlier comment about trying unsuccessfully to enable debug.

    Thanks for all for your assistance, I appreciate it greatly. Paul

    #1067932

    verycunning
    Member

    Any further suggestions for investigation? Thanks.

    #1067933

    kardotim
    Member

    Could you please check if the debug.log file has the proper (write) permission rights? Please make sure you set the permissions to 666, 777 or check all ‘write’ checkboxes when viewing the file’s properties.

    #1067934

    verycunning
    Member

    Yes, when I created the file I set it to 666.

    #1067935

    kardotim
    Member

    Could you make it 777, just to be sure? you can also (temporarily) enable the WP_DEBUG_DISPLAY to see if it’s working properly.

    #1067936

    verycunning
    Member

    Set to 777
    I set WP_DEBUG_DISPLAY to true (but did not change @ini_set(‘display_errors’,0); ).
    I still don’t see anything in the file (size 0).
    The full path to the directory is /public/blog/wp-content, I’m concerned that this needs to be set somewhere but perhaps isn’t. (Otherwise blog site seems to work fine.)

    #1067937

    kardotim
    Member

    Could you try and set display_errors to 1? Also make sure to download the debug.log file and open the file in a text editor to see if it contains text.

The topic ‘Can't make initial connection to WordPress.com?’ is closed to new replies.