Can't post a comment – "Blocked as suspected bot"

  • Author
    Posts
  • #2818069

    skunji
    Member

    I’ve been informed by a reader that they are unable to comment on my blog, and when they try they are getting a blank screen with this message “Blocked as suspected bot”. I went incognito and tried to leave a comment and got the same results.
    Comments are enabled and need manual approval. We tried turning off Akismet, but no difference.
    We’re using WordPress platform hosted on Bluehost. Also using the Genesis Framework with Wellness Pro child theme. Don’t know at what level this is happening. Any idea?
    Here is the post I’m trying to comment on, although I’ve tried on several posts and get the same result. http://www.going4ward.com/goodbye-to-cravings-goodbye-to-food-addiction/

    #2818293

    carinharris
    Member

    I’m having the exact same problem. Have yo resolved it yet?

    #2818497

    xeeshantech
    Member

    I am also having the same problem and not yet resolved. Also tried to deactivate Akismet

    #2818505

    skunji
    Member

    Yes, we finally got this resolved. It’s a little weird and I don’t know why it worked, but I deactivated MOJO Marketplace. I found the suggestion in a google search and it worked fine. No problems since.

    Hope it works for you too!!

    #2818506

    sampandian
    Member

    @skunji, it worked for me too. Cool. Thanks.

    #2818507

    timethief
    Member

    This is wordpress.COM support.

    WordPress.COM and WordPress.ORG are completely separate and have different username accounts, logins, support docs and support forums, and many people get confused about the two.

    The wordpress.ORG login link is here https://login.wordpress.org/ If you do not have an account yet then click Create an account https://login.wordpress.org/register/ and if you have lost an account password click Lost password? https://login.wordpress.org/lostpassword/

    This is wordpress.COM support. We provide support only for wordpress.COM hosted sites. Our support docs do not apply to
    (1) local installs of wordpress.ORG software on your own server or
    (2) wordpress.ORG software installs on paid hosting, and we do not provide support for them at wordpress.COM.

    Also, note that we do not provide Jetpack support https://jetpack.com/support/ for sites linked to wordpress.COM accounts with the Jetpack plugin so they display on the My Sites wordpress.com account page.

    Some Jetpack solutions are here http://jetpack.com/support/

    Others are in the Jetpack support forum at WordPress.org
    http://wordpress.org/support/plugin/jetpack

    However, if help cannot be found at either one then they can file a Jetpack support ticket here > http://en.support.wordpress.com/contact/?jetpack=needs-service

    WordPress.COM and WordPress.ORG are completely separate and have different username accounts, logins, features, run different versions of some themes with the same names, and have separate support documentation and separate support forums. Read the differences here http://en.support.wordpress.com/com-vs-org/

    WordPress.org support docs are at https://codex.wordpress.org/Main_Page
    See also https://apps.wordpress.org/support/

    #2818541

    @timethief – Sounds like you aren’t really in the support business at all :-)

    While it is important for everyone to know the difference between the .org and .com versions of WP, this is a problem for lots of users, and the issues are common between the two versions; so answering the question will help both the self-hosting and wp.com clients. Just copy-pasting the boilerplate isn’t support, and feels like a RTFM answer.

    Simple question and apparently it has a solution – thank you skunji!

    #2818546

    yangg511
    Member

    thank you for solving this. i had the same problem.

    #2818547

    timethief
    Member

    You’re welcome.

    #3142644

    Hi everyone,

    I come here from Google searches. Since this issue happens quite often, I’d like to give some insights for a quick solution.

    If you see “Blocked as suspected bot”, it is caused by Bluehost or Mojo Marketplace plugins. Solution: you can temporarily disable these plugins or better contact your hosting provider Bluehost to get help.

    —–

    The following information is pretty technical, you may ignore it :)

    “Blocked as suspected bot” can be found here https://github.com/mojoness/mojo-marketplace-wp-plugin/blob/master/inc/spam-prevention.php#L135

    The code line may be changed but the code looks like this:

        $spam_key = md5( $_SERVER['HTTP_USER_AGENT'] . $_SERVER['REMOTE_ADDR'] );
        if ( ! isset( $_POST['js-spam-prevention'] ) || $_POST['js-spam-prevention'] !== $spam_key ) {
            if ( current_filter() !== 'registration_errors' ) {
                die( 'Blocked as suspected bot.' );
            } else {
                $data->add( 'bot_error', 'Suspected bot.' );
            }
        }
    

The topic ‘Can't post a comment – "Blocked as suspected bot"’ is closed to new replies.