Need help? Check out our Support site, then

can't publish post

  1. can't publish post - Hey y'all. yesterday I tried to write a post and hit publish and the icon for publish just spun and spun and never made the post. I tried it a bunch of times, closing all my browser windows etc., but to no avail. Any help? Thank you.
    Blog url:

  2. please try upgrading or switching first.
    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    If you are, please do these four things:

    1. Try clearing your browser’s cache

    2. Make sure that you have third-party cookies enabled

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

    If you aren’t successful let us know which browser (and version of it) you’re using and post any error reports you get.

  3. Rats! I left off a sentence at the beginning of my comment above.

    If you are not running one of the browsers and versions listed at please try upgrading or switching first.

  4. Hi!

    I ran into the same problem today. I copied my post and tried posting it from my blog (the front page, not the backend). That helped me. Hope your problem has a solution :-)

    Best regards,

  5. Thanks amalieardahl

    if you aren't doing so now then I recommend that you log-in directly to your own blog by using this link

    There's an issue with creating posts on the front page of that will not be fixed until the next upgrade. Do not create posts here >!/post/

    Instead I recommend that you ONLY create posts here > Dashboard > Posts > All Posts > Add New

  6. Thanks for all the help! I am so not tech savvy, but from your suggestions I've figured out it is my browser so I did the blog from Google Chrome this time (which I hate because it has pop ups that I can't figure out how to make go away) but it worked so thank you!

  7. You're welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic