Can't register a new blog

  • Author
    Posts
  • #1360066

    Hi
    I have been with WordPress.com for 6 years and have 2 active blogs and a couple of others. For ths last few days I’ve been unable to register a new blog, getting an error page in IE or ‘no data’ on Chrome. I have tried clearing cache.
    Other admin pages are also intermittently failing to load.
    I have noted this thread
    https://en.forums.wordpress.com/topic/unable-to-load-the-webpage-because-the-server-sent-no-data?replies=61
    which suggest s the Talk Talk provider may be to blame.
    I am with AOL as I have been throughout my time with WordPress.
    Do you think this is a browser issue or something else?
    Ali B http://debutnovelist.wordpress.com

    The blog I need help with is alibacon.com.

    #1360186

    Update: I have now tried using a different PC and a different browser viz. firefox. I did manage to get to the ‘sign-up for new blog screen’, but could not proceed further as hung up at the ‘checking domain name’ stage. This was followed by inability to login again to WordPress.
    Back on my usual laptop but becoming seriously frustrated. Is this likely to be a provider problem, (AOL) or is there something happening with WordPress servers?

The topic ‘Can't register a new blog’ is closed to new replies.