Can't set new static home page in Twenty Twelve

  • Author
    Posts
  • #1958502

    appraiserart
    Member

    New to WordPress! Creating website with blog using Twenty Twelve. Trying to make the
    “HOME” page a static page. Created a “welcome” page I want to use for static page. When I go into settings and try to set the new home page, my only choice in the drop down menu is “Blog”. None of my other pages appear. What am I doing wrong? Or, can the home page not be changed in twenty-twelve?

    The blog I need help with is appraiserart.wordpress.com.

    #1958606

    jsmutek
    Member

    Hey – the home page can be changed in 2012 – are you sure you created pages?

    It sounds like you might have made posts, instead of pages. Posts won’t show up in the drop down box under settings/reading.

    Does this help at all?

    #1958622

    timethief
    Member

    By default the front page of your blog displays all published posts (not pages) in reverse chronological order, with the most recently published post on top. That is for the convenience of your returning visitors, who come to read your latest post, and who are not likely to be happy with being compelled to click through the same static page with the same blah, blah, blah on it every time they visit the blog looking for the latest post.

    However, if you do not want all the posts to show on the front page, and know that static front pages are traffic killers, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts. To do that create two pages first http://en.support.wordpress.com/pages/

    After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    #1958646

    appraiserart
    Member

    Thanks, everyone. Sorry, my mistake. I made all my pages private, not published as “public”, since I am working on the site and don’t want it live yet. However, the static page had to be made “public” before it would be recognized in settings. Problem solved.

    #1958678

    jsmutek
    Member

    Yay!

    #1958744

    timethief
    Member

    @appraiserart
    You’re welcome.

The topic ‘Can't set new static home page in Twenty Twelve’ is closed to new replies.