Can't Upload Photos, Link Doesn't Work

  • Author
  • #787825


    Has anyone else noticed a lot of difficulties uploading photos to WordPress lately (the past month or so)? The link simply doesn’t work, the link for Uploading Media. I try to upload photos in many different ways, from within the new post that I am drafting up, from within the “Media” section, but the link simply doesn’t work for me. I updated Firefox like WordPress recommended but it hasn’t made any difference. This is really turning me off of continuing with my blog. Any help anyone?

    The blog I need help with is



    Hello there,
    Staff made some changes awhile ago. Drag & Drop Media Uploader Have you tried clearing your browser cache and cookies? Note that if your browser version is outdated you can upgrade here.



    Hi Timethief. Oh thank you so much for replying! Yes for a while I was using the new Drag & Drop Media Uploader and it worked great. But for the past few posts that I have been trying to post, I can’t get ANYTHING when I click on the Upload Media link. I have tried signing out and signing back in again, refreshing the page, etc. but nothing works. I am using Mozilla Firefox. Should I try a different browser? I don’t have any other browsers except the typical Internet Explorer, which has always given me lots of problems. Yes I clear the cache and cookies every day. And I just updated Mozilla Firefox using the link that WordPress sent me. So I don’t think it should be any of those things.



    Upgrading your browser and clearing the cache and cookies was a good thing to do. Browsers are extremely aggressive when it comes to caching these days. I have my Firefox 9 set up to automatically clear my cache and cookies every time I close the browser. Are you running any extensions or add-ons? Have you tried using the browser with all extensions or add-ons disabled?

    Let’s try and track this down.

    Are you using http:// or https:// ? see > Sometimes switching works.

    Do you have third party cookies enabled?

    Do you have JavaScript enabled?

    You can use this link to see if your Flash is up to date. If it’s not up to date then this is where to download and install the latest version of Flash.

    Have your tried resetting your router and modem?



    Hi Timethief! Oh that is so nice of you to help me! Well I just downloaded the latest version of Adobe Flash from the link you have. I really have no idea whether I am in http or https, I’ll pay attention the next time I try to post a new post. I’ve tried to remove all add-ons and extensions since I don’t like them, there is one that refuses to leave though even though I don’t like it. It doesn’t seem to do anything, it just sits there. It’s a search engine called SweetIM. Oh well I tried to follow your link to third party cookies and JavaScript because I have no idea what they are, but I can’t follow those links without leaving the forum, so I will do that later. Should I try disabling them if they are enabled?

    At any rate I was able to post a post because I discovered that if I signed out, then waited a long time, I don’t know how long, long enough to do another task, and then signed in again, waited a few minutes for the entire “thing” to finish downloading, then I could put up one photo. After that the link stopped working again. So I saved the draft, signed out and waited a long time again while I did another task, signed back in again, waited a few minutes etc. That way putting up one photo at a time I could post a post. But that really ________! No one can go about posting a whole blog using this method all the time!

    Maybe I will wait until Support comes back from holidays and write to them, since I will not be posting again for like about 50 more years if this problem continues, because it is so discouraging!

    Well, maybe it is just slow to complete downloading into the computer, and if the downloading is not complete, the links don’t work.

    Thank you so much, Timethief. I hope to solve this problem soon because I do like blogging.


    After struggling with this last night I also can’t seem to get the “from URL” feature to work for images. Most Most frustrating to a new blogger. I followed the suggestions. My images are on flickr and when I paste the short or full link into the URL box I get the red X. I was able to set up a flickr account and post directly from there but I would also like the option to link. Tried again this morning after a reboot and clearing cookies and it still didn’t work.



    @sailingarkansas – the link given is to a PAGE not the image – the link you use to embed a photo needs to go to only the Photo no page or anything else – I was not able to find that link – I don’t do Flicker so I don’t know if it is a problem with your setting on the account or if you have access to a better link when you are signed in.

    Bottom line – the link you use here needs to display Only the picture you want to embed – maybe another volunteer with flicker experience will stop by this morning with more help.


    I knew that wasn’t the image name but that was all I could find on Flickr. After more research I found the following on Flickr.

    How do I get the URL of a photo?

    To use the URL of a photo (like when you add a photo to your Blogger profile), you must provide the web address (URL) of the image itself, not the address of the web page where the image is displayed.

    Here’s an example of a correct URL for a photo. Note the .jpg at the end:

    Here’s an example of an incorrect URL for a photo. It points to the web page where the image is displayed, not the image file itself. Notice there’s no .jpg at the end.

    (Click both of these links to see the difference.)

    You can get the URL of your own images on Flickr. To do this just click “Actions” and “View all sizes.” You can then right-click to get the URL of the photo.

    Note: Per our Terms of Use, whenever you place an image you’re storing on Flickr on an external web site, you must also include a link back to Flickr.

    that seemed to work. Thanks!


    A bit more info in case someone else has the issue. The instructions aren’t quite intuitive. Once you get to View all sizes then you right click on “Download the Large size of this photo”. Not the actual photo.


    This is getting on my nerves now and WordPress seem to have little interest in resolving the issue, instead they keep telling everyone that it’s our fault and that browsers need updating etc.

    So I have been having this problem for months and everytime I post something here I am told to check browser, check cache etc.

    It doesn’t work. The problem is with the WordPress code. There is come king of jQuery conflict going on somewhere.

    Today I have had to clear my cache 11 times. Do you see that WordPress, 11 times (it’s only 10:30 am now!). And now I am trying to post again and the Add Media button is once again inactive.

    TimeThief will helpfully tell you all to clear your cache, update your browers and waffle about https for a bit. That will fix it for 5 minutes. Other than that there is zero help coming from above and it seems very little interest in fixing this huge bug.

    It seems interesting to me that no matter how many times I mention this and no matter how many times I mention what steps I have taken to resolve it the response is always the same. See TimeThief above… “Let’s try and track this down” – the while post is verbatim what was said to me three times already, it’s either automated or simply copy/paste..



    Neither timethief is a staff nor you are paying for the help here.
    The volunteers can not solve your problem by themselves but they can only give you suggestions to solve the problem. So be patient here while you’re solving any problem. Don’t be so rude.

    If you are in a serious trouble contact support or at least create your own thread to share your problem.


    Thanks for your tip but you are totally unimformed. Every part of your post is rubbish.

    1. I know WordPress is free but something free that doesn’t work isn’t much use to anyone.

    2. “Don’t be so rude” – There was nothing rude about my post, nothing. It was descriptive of my experience here and when referring to TimeThief it said “TimeThief will helpfully tell you…” so am I being rude calling TimeThief helpful?

    3. I have been patient for three months! How much longer?

    4. Multiple threads have been created before but no help.

    Any more worthless advice?



    Hi, Marbella is a Spanish city.
    There are a lot of problems reported from Spain with the media uploader and other features:

The topic ‘Can't Upload Photos, Link Doesn't Work’ is closed to new replies.