Can’t use the Flash uploader on a Mac? I may have a solution…

  • Author
  • #319305


    Hi All

    I’m posting this because I’ve been tearing my hair out for weeks trying to suss this out, and I couldn’t find any solutions online.

    When I tried to use the Flash uploader in WordPress 2.7 with a Mac (both Safari and Firefox) with Flash 10 I would get an HTTP Error message, whereas I could upload fine from a PC, both IE and Firefox, with Flash 10.

    After having gone through lots of ideas, I finally hit on the fact that the site was behind an htaccess / htpaswd restriction because it was in development and I didn’t want other people to see it.

    When I commented those lines out of the htaccess file it worked perfectly.

    I have a feeling that this also applies to some plugins, like the WordPress Authentication Plugin, with which I had the same problems. (I can’t check this, because that blog has to stay on 2.6 for various reasons, and the 2.6 Flash uploader doesn’t seem to work at all with Flash 10).

    I’m guessing it’s because Flash is more tightly integrated with browsers in Windows, whereas perhaps Flash on a Mac doesn’t pick up the authentication information from the browsers. Or something…

    Anyway, I thought that might save someone else’s hair!




    @adriantoll, here at wordpress.COM, we do not have access to any of the underlying theme or wordpress files, or htaccess, so the solution will not work here. My suggestion is to post this at the forum that supports self-hosted blogs, http://wordpress.ORG/support/ .

    By the way, Mac’s work just fine with the uploader as long as you have flash 9. I’ve been very reluctant to upgrade for 10 because I don’t want to encounter issues.



    Doh. I’ve seen so many posts along the lines of “don’t you know the difference between and” – never thought I’d be the culprit!

    For what it’s worth, 2.7 from works fine for me on a Mac with all the newest updates installed for the OS, Flash etc., but I don’t know what’s setup is like…



The topic ‘Can’t use the Flash uploader on a Mac? I may have a solution…’ is closed to new replies.