Categories don't seem to be working

  • Author
    Posts
  • #798621

    picturette
    Member

    I have added the category widget to my sidebar but when I click on them it takes me to a blank page. I have added tge count so I can see there are definitely posts in that category. The category link below each post works but not the category links in the sidebar. I have waited a few days and tried it at different times in safari and firefox but I get the same result. Have I missed a step? Thanks for your help.

    http://picturette.wordpress.com/

    The blog I need help with is picturette.wordpress.com.

    #798794

    timethief
    Member

    We create Categories in our dashboard > http://en.support.wordpress.com/posts/categories/#adding-categories-via-your-dashboard
    We assign categories to posts (not pages) in the Categories module on the posts http://en.support.wordpress.com/posts/categories/#adding-categories-with-the-categories-module
    The Categories widget has no data to display in any category until we actually publish a post in that category. http://en.support.wordpress.com/widgets/categories-widget/

    #798798

    timethief
    Member

    I have checked out your blog and I cannot find posts that actually have categories assigned to them and displaying on the posts themselves. Do you have a custom design upgrade and have you done any CSS editing on this theme?

    #798799

    picturette
    Member

    Thanks for the quick response. I do have a custom design upgrade and have edited it a bit (I don’t have much experience with this so am trying to keep it simple). I am pretty sure the only things I have edited are colours, padding, borders etc. I don’t really understand how widgets work but I didn’t think I could alter them with css.

    #798802

    timethief
    Member

    All themes display categories and tags either at the top of posts at the bottom or on the side. Nishita displays them at the bottom of all posts http://theme.wordpress.com/themes/nishita/ None of your posts have categories displaying. Consequently that led me to believe that you have done some CSS editing that eliminated the display.

    #798805

    picturette
    Member

    I can see them at the bottom, in between the date and comments. I just double checked and I have definitely assigned categories to all of my posts. When I view ‘all posts’ I can see that they all have a category (not just uncategorised) and in the sidebar I can see the number of posts in each category e.g. illustration (3). but those three posts do not come up when I click on that category link in the sidebar, I get a completely blank page.
    Now the category link below each post is also not working. Maybe I’ve missed something? I went through the links you suggested and I’m pretty sure that’s exactly what I have done.

    #798812

    timethief
    Member

    I did a random check of the post themselves. Here are two examples of posts that are no displaying categories links.
    http://picturette.wordpress.com/2012/01/11/festival-first-night/http://picturette.wordpress.com/2012/01/12/terrace-houses/

    I believe your have accidentally removed the display via CSS editing. I have flagged this thread so it will be moved to the CSS Forum where you can get help.

    #798815

    picturette
    Member

    So I did! Sorry to waste your time.

    #798819

    timethief
    Member

    Not to worry, I removed the flagging. :)

The topic ‘Categories don't seem to be working’ is closed to new replies.