Category Confusion

  • Author
    Posts
  • #94885

    jamaal
    Member

    Hi

    I need help with Categories. I have main Categories called Articles, My Thoughts, and Photo Galleries.

    Under Articles I have sub-categories for the months of the year. I currently have only 2 posts, and they are both under the March 2007 sub-category.

    My problem is that when I click on Articles in my first sidebar, the main column comes up with BOTH my artciles that are in the March 2007 sub-category. I would like to click Articles, and then have all the sub-categories come up, and then when each sub-category is clicked I want all the posts for that sub-category “listed” (not displayed) – and then the visitor must be able to click on whichever article he/she wants to read.

    Please help me with this!

    #95014

    drmike
    Member

    You would have to edit the theme to be able to do that and, since we’re on a shared environment, you’d be doing that for everybody who used that theme,

    #95015

    judyb12
    Member

    One way around this is to write a page that contains the parent categories with links to the subcategory pages and remove the Categories widget from your sidebar. You would then use the Pages widget instead.

    Category links look like this:
    http://YOUR-BLOG-NAME.wordpress.com/tag/CATEGORY-NAME/

    #95018

    jamaal
    Member

    Judyb12 – I have seen your blog and I would like something like that. COuld I chat to you on MSN for assistance please?

    #95024

    judyb12
    Member

    Jamaal,

    here’s the code you need to use. Make sure you are writing a Page (not a post) and click on the Code tab of the editor before pasting this stuff in there.

    1. Replace YOUR-BLOG-NAME with your blog name (for you, i think it will be Jamaal).
    2. Replace CATEGORY-NAME1 (2,3,4,5,6) with the name of the category.
    3. Replace CATEGORY 1 (2,3,4,5,6) with the name of the category (this will be the text that people click on)

    <ul>
    	<li><a href="http://YOUR-BLOG-NAME.wordpress.com/tag/CATEGORY-NAME1/">CATEGORY 1</a></li>
    	<li><a href="http://YOUR-BLOG-NAME.wordpress.com/tag/CATEGORY-NAME2/">CATEGORY 2</a></li>
    	<li><a href="http://YOUR-BLOG-NAME.wordpress.com/tag/CATEGORY-NAME3/">CATEGORY 3</a></li>
    	<li><a href="http://YOUR-BLOG-NAME.wordpress.com/tag/CATEGORY-NAME4/">CATEGORY 4</a></li>
    	<li><a href="http://YOUR-BLOG-NAME.wordpress.com/tag/CATEGORY-NAME5/">CATEGORY 5</a></li>
    	<li><a href="http://YOUR-BLOG-NAME.wordpress.com/tag/CATEGORY-NAME6/">CATEGORY 6</a></li>
    </ul>

    Once you have that pasted in, you can switch back to the Visual tab on the editor to see how things look and to put in whatever other text you want.

    Good luck!

    [Edited to make minor corrections]

    #95041

    jamaal
    Member

    Hi Judyb12

    Thanks very much. I struggled a bit, but I got it to work! :)

    I have 2 quick questions.

    Firstly, my posts are very long, how can I post only one or two paragraphs with a “read more” link?

    Secondly, I am using this forum a lot. Is there anyway to get an email notification when someone replies to me?

    Thanks so much!

    Jamaal

    #95045

    timethief
    Member

    inserting the more tag <!–more–>
    If you have not turned of the text rich editor then icon 13 is the one to use
    http://faq.wordpress.com/2006/05/15/what-do-all-the-icons-mean/

    If you have turned the text rich editor off on Your Profile page then you are using the standard editor. In that case then use the [more] button to insert the break into the text.

    There is no means of receiving email updates to forum posts. It’s up to you to come back and see what answers your fellow bloggers have voluntarily chosen to share with you. Everyone answering you that does not have “Key Master” after their name is a volunteer.

    This is a link to some basic resources that you can use to find answers to your questions https://en.forums.wordpress.com/topic.php?id=5257&page&replies=19 :)

    #95046

    jamaal
    Member

    I came right, thanks!

    #95048

    jamaal
    Member

    Actually, I did not come right.

    The problem is my editor looks different. I think I have a brand new editor. I still need to make my posts short with a read more option.

    #95049

    jamaal
    Member

    Ooops! The <!–more–> tag worked! Thanks! :)

    #95050

    timethief
    Member

    Please go to this page => Dashboard =>Users => Your Profile
    On this page you can place a mark in the checkbox where it says ___ “Use the visual rich editor when writing.” After doing that click “Update Options” to save. Now to insert the <!–more–> tag into your text you can use icon 13.

    From time to time the visual rich editor may inexplicably shut off so it’s good to remember where you can go to turn it on again.

    Also note that drmike had an idea to share with you regarding the “hide text” regarding the header on the Connections theme blog. You can use a program like MsPaint with the image and place your blog title anywhere on that image and then upload it as a header. https://en.forums.wordpress.com/topic.php?id=9811&page&replies=8#post-67924

    Happy Blogging :)

    #95057

    jamaal
    Member

    Hi

    Thanks for the info, but my rich editor is ticked under profile, but when working with posts I dont see any icons.

    #95064

    timethief
    Member

    Oh dear … It is very probably a browser cache error.
    With your browser open on the Write Post screen press:
    Ctrl and F5 together (Windows)
    shift+reload (Mac)
    F5 (Linux)
    This forces a full page reload and the buttons will appear.

    If you are using the Adblock extension in Firefox, open it, click Preferences, click Exception Rules and add this as a filter:

    @@|http://*.wordpress.com

    #95066

    drmike
    Member

    What browser are you using? We know Safari on the Mac has issues with the javascript that the editor uses.

    #95071

    jamaal
    Member

    i’m using ie6, but i’m gonna install ie7 and see if that works

    #95101

    raincoaster
    Member

    If you can use IE7 it should probably work better. I can’t install it, so I can’t compare, but I do know there are known IE6/Wordpress issues.

    #95113

    jamaal
    Member

    Thanks!

The topic ‘Category Confusion’ is closed to new replies.