Change caption font size

  • Author
    Posts
  • #762867

    wordstodeeds
    Member

    Hi everybody,

    I would like to add credits under photos, but the caption font size is too big (11px in the theme CSS – Chateau). I have the Custom CSS option on my blog, and have tried to change to 7px by adding a stylesheet, but nothing has changed.

    Can anyone help?

    The blog I need help with is wordstodeeds.com.

    #763060

    Do you have a link to a post or page with a caption? On the site linked to your username, http://wordstodeeds.wordpress.com/ , I’m not seeing any captions.

    #763062

    wordstodeeds
    Member

    Thanks for replying so quickly sacred path.

    No, I took it out because it was so big. Do you need me to post an example? Can I do that without publishing it publicly?

    #763065

    The demo site here doesn’t have any captions on the images. I rummaged through the CSS and found this which may or may not control it. There is another place where a font size is set for caption related stuff.

    .wp-caption .wp-caption-text, .gallery-caption {
    font-size: 13px;
    }
    #763067

    wordstodeeds
    Member

    Yes, I think that is what I tried to change using the “add a stylesheet” function, but nothing changed. I’m scared to actually change the original theme CSS. :)

    #763070

    You cannot change the original CSS. What you put into the CSS edit window, overrides the like things in the original stylesheet.

    I had to switch one of my test blogs to Chateau, start a test post, upload and insert an image so that I could see the caption.

    The code above, pasted into the CSS editor with the 13px value changed to 6px results in tiny text that no one can read, so the code above is working.

    #763074

    wordstodeeds
    Member

    Fantastic Sacredpath! I must have copied too much code before, because it works now! Just one thing – there is a dash to the left of the text which is rather ugly. Can I get rid of that?

    #763075

    This will do it.

    .wp-caption .wp-caption-text:before {
    content: none;
    }
    #763076

    wordstodeeds
    Member

    Fantastic!! Thank you SO much.

    I don’t want to take advantage of you, but I have also posted another question – I need to add some notices (disclaimer, credits etc) that I want to link from a footer widget. I don’t want them to be dated posts, and I don’t want them to appear in the top menu. How can I do this? I tried using “Page” but they always appear in the menu.
    Please tell me if I should wait for an answer on the other thread – as I said I don’t want to take advantage of you.

    #763078

    Create a custom menu and then you have complete control over what appears in the top menu. You can include the pages you want and leave the others out.

    #763082

    wordstodeeds
    Member

    Whoopee!! I’m almost sorted thanks to your invaluable help. How can I stop the comments box from appearing below the text of the page? As they are legal notices comments are not really appropriate.

    #763084

    Open the page in the editor, go to the screen options tab at the far upper right, activate the “discussion” module and then you can turn off comments there. It will be down below the main text area in the editor window after you activate it.

    #763085

    wordstodeeds
    Member

    Fantastic. I can’t thank you enough. Crystal-clear instructions too.

    Have a wonderful Monday!

    #763088

    You are welcome, and you too.

The topic ‘Change caption font size’ is closed to new replies.