Change in RSS feed?

  • Author
    Posts
  • #688817

    ismailimail
    Member

    I have been noticing a change in the RSS feed format (I use Google Reader) since yesterday. The feed shows additional “Share this via…” links. See this for example,

    This shouldn’t show up in the feed like that. Is this something related to my blog or common issue in general?

    The blog I need help with is ismailimail.wordpress.com.

    #689035

    macmanx
    Staff

    I’m not noticing this myself. Please make sure that you have subscribed to your feed: http://ismailimail.wordpress.com/feed/

    #689062

    ismailimail
    Member

    I made some posts today and I see this again. However, it isn’t showing up under all posts. See this screen shot for example.

    I have subscribed to my own feed in Google Reader.

    #689063

    ismailimail
    Member

    Not sure if it could be helpful to you, but the word “Share this via” is something I typed in Settings – Sharing section for Publicize. This shouldn’t show up in the RSS feed, right?

    #689068

    macmanx
    Staff

    Ok, that’s really strange. I’m going to pass this on to the folks who can dig a bit deeper than I can.

    #689072

    macmanx
    Staff

    This is all fixed up now. Feeds are generally cached until new posts are made, so you may not notice a change until you publish a new post.

    #689097

    ismailimail
    Member

    Hi, this problem reappeared today (for the last two posts I made). Although it was generally fixed for my blog since you posted your comment, but I have noticed the same issue on feeds of some other blogs hosted here (not mine). Please check.

    #689100

    ismailimail
    Member

    I confirm, this issue is back. Made few posts this morning and the RSS feed doesn’t look right in at least Google Reader.

    #689106

    Thanks for the reports! We see this as well and I’ve reported it to make sure we get things taken care of. Cheers!

    #689114

    ismailimail
    Member

    Hi, any update on this?

    #689115

    drespena
    Member

    I see it as well. Would like to get rid of it.

    #689116

    ismailimail
    Member

    Dear staff, any update on this?

    I am identifying some culprits for you via sceenshots. These are from my feeds today.

    1. These are the broken links in the feed, as you know.

    2. I am wondering where are these social-links coming from in my feed? I don’t see any settings to disable them and I believe these are the culprits. If you note in this particular screenshot, that this is a properly formatted feed; however, it has these social links which I have not enabled on my own. I am also identifying the URL which they point to.

    The properly formatted feed and the improperly formatted feed are both from today’s postings on my blog. The properly formatted feed/post has links to social platforms (which I would prefer to add or remove on my own), but the improperly formatted feed does not have these social links, and this could possibly be the culprit of the formatting issue.

    3. Here is the screen shot of two of my settings which seems relevant.

    Settings – Reading
    Settings – Sharing

    I appreciate your help in resolving this as soon as possible.

    #689117

    ismailimail
    Member

    Could I please get any update on this?

    #689118

    Howdy, thanks for the screenshots. I’ve passed them along to the team so that they can take a look. We’ll look into things and update you here if we find anything amiss. Thanks.

    #689119

    Alright, so the way the links in your RSS feed are appearing is through the same Settings > Sharing tool. Some of the sharing buttons there will also appear in your RSS feed.

    For example, if you have StumbleUpon added in Settings > Sharing you’ll also see it in your RSS feed. If you remove it then it will also be removed from your feed. With most RSS readers they cache the feed for a while so any changes you make to sharing buttons may not be immediately visible in your RSS reader.

    #689120

    ismailimail
    Member

    So how do I fix this problem from my end without removing the Sharing icons?

    #689121

    That is the only way to remove the links in your RSS feed as the feature stands right now.

The topic ‘Change in RSS feed?’ is closed to new replies.