Change of twitter post @username

  • Author
  • #1014361

    I’m trying to unlink a twitter account from my blog on Whenever I use copy paste to share my blog post it posts the blog using the username from my personal twitter account e.g. @melissa and not from a separate twitter account even though I am logged into that account. But it only works this way when I’m trying to post blogs from WordPress. Not sure if this is WordPress related or Twitter related. I can’t seem to find information on how to change this behavior.
    Blog url:

    The blog I need help with is



    Is your Twitter account connected to your blog on the Sharing page? You will have to disable that.


    In my Sharing settings under publicize Twitter is disconnected. But I’m thinking that the information has to be stored somewhere in order for it to insert it on my tweets. Would you please tell me where and how would I disable that if I am looking in the wrong place?

    Just to clarify, what’s happening Is that whenever I post my blogs they are read as being written and posted by my twitter name and not the name that I have on my blog. For example, when I tweet my post, it has my blog title and then under that it reads, By mytwittername @mytwitteraccount.


    Can someone disable the plugin on my account from the admin side? I don’t have access to plug-ins from my console or I would disable it myself. Please help.




    RATS! I have misunderstood you. Sorry. Staff have been working on Publicize and rectifying the issues with it. See here >


    But what I’m trying to do is to take my twitter information off of my blog or at the very least, change the twitter account that this is associated with. Can someone help me with how to do this?


    Ok thanks! I’ll check it out.



    Have you tried disabling it exactly it where you connected it > Dashboard > Settings > Sharing


    Yes. I tried that. And I just made a test post. My blog site is I created the post. Then I enabled Twitter on the publicize settings. I then connected it to the twitter account that I want to post to. Then I checked to make sure that it was posting under the correct username.

    Well, it posted to my the Twitter account that I want to use, but when you click on the post to view the blog title, it says that it is written by my old twitter account name and directs people to my old twitter account.

    How can I get it to say that it’s written by my NEW twitter name and point to my NEW twitter account?


    Hi there,
    I’m the same person logged in under my other username account.

    “We’ve identified an issue with autocompleted mentions on Twitter for iPhone and iPad versions 5.0 and 5.0.1 running on iOS 6. … ” read in whole post here >


    I think I’m still explaining this wrong or something. So, I’ll try to explain it exactly as it is happening.

    I compose my post
    It posts to twitter.
    This is and example of what posts on twitter

    Be Yourself (actual post)
    By JustChelle @chamella.(old account)

    What I would like for it to say is:
    Be Yourself
    By Sweet Melissa @melissa_martin7 (new account)

    Can someone tell me how to make this happen?


    Just checking to see if anyone has any updates on this. Is this a known issue? Or is it known whether or not this issue is related to WordPress?




    Unfortunately, that’s a cache on Twitter’s end which we have no control over. They should clear it automatically eventually.


    Question – why would Twitter have a say in who the author of my blog is? Am I missing something? Another issue I see with saying that it’s a Twitter cache problem is that when I reviewed previous posts to Twitter from nearly a year ago they appear to have the same format. Would you by any chance know how often they clear the cache on Twitter?

    That said, when I set this account up almost a year ago I had access to Plug-ins that I no longer have access to because this is not a hosted blog. There must have been a setting that I used then that I don’t have access to now.

    So, my question is this, who can delete the plug-ins (specifically the ones that are associated with shared info on other social networking sites ( I believe)) that are associated with this account? Or, is there another way that I myself can access the plug-ins to change or delete the information?

    I’ve made sure that WordPress is not associated with my old twitter account by deleting all app approvals and making sure that WordPress is not listed on that account at all. I’ve deactivated Twitter on the Sharing page in WordPress and I have unlinked it in every way that I can in Twitter and WordPress. I currently don’t have any authorized apps in either program.

    Is there no way through WordPress that I can choose to display my name as the author of my blog on other social networking sites? I thought that perhaps it would be on a profile or preferences page but that doesn’t lead me anywhere. If I could disassociate the site with Twitter all together that would be ideal. But so far that doesn’t seem to be an option. Lots of info on how to link your blog to twitter, and how to start or stop it from automatically tweeting your blog, but nothing on the subject that I am asking about.

    *** With all due respect, please do not post messages of how to connect my blog to my twitter account. I already know how to do that. I’m trying to FIND A WAY WITHIN WORDPRESS TO CHANGE THE AUTHOR OF MY BLOG SO THAT IT WHEN IT POSTS ON TWITTER IT SHOWS UP WITH MY NAME AND POINTED TO THE CORRECT TWITTER ACCOUNT ***

    If all else fails, can this be escalated for further review or is there such a thing as escalation? If not, what are your thoughts on moving this blog to another newly created WordPress blog?

The topic ‘Change of twitter post @username’ is closed to new replies.