Change speed of slide show in Dara theme

  • Author
    Posts
  • #3067398

    Hi,

    I am using a slide show to feature important images on the home page. Each has captions that are important to the image, but the slide show moves so quickly it’s really difficult to read them. Is there a way to slow down the slide show? Or is there another theme that allows this?

    On a related note, is there a way to make photo captions multi-line in the slide show?

    The blog I need help with is atomscienceclubblog.wordpress.com.

    #3067528

    justjennifer
    Moderator

    Hi there, Do you mean the 2 Gallery slideshows that appear on your homepage? If so, it’s not possible to change the timing between images.

    It is possible to add a parameter to the slideshow after you’ve inserted it which prevents the slideshow from auto-starting and advancing. This means that visitors will need to advance the slideshow manually.

    However, it appears that something is broken with that at the moment and I’ve tagged this thread for Staff attention. Thanks for your patience.

    #3067529

    justjennifer
    Moderator

    Staff, On my test site I’ve just added the autostart=”false” parameter to my test slideshow created in the New Dash/Calypso Editor and when switching back to the Visual Editor, the autostart=”false” parameter doesn’t work.

    Switching back to the HTML Editor tab shows that the gallery shortcode has all kinds of extra code added to it (temp screenshot). This shouldn’t happen.

    I’m using FF 57.0.4 (64-bit)

    #3067539

    Thank you for the testing :) I’ll try to reproduce as well and make an internal report.

    #3067558

    Hmm. I think it’s related to this: https://core.trac.wordpress.org/ticket/42908

    #3067559

    I am able to make the “false” parameter stick and work with these steps.

    – Open text editor, add parameters
    – Save parameters (stay in text editor)
    – View post

    #3067566

    justjennifer
    Moderator

    Thanks @lizkarkoski – 4.9.1 involves the WP Admin Editor, but it also happened for me in my test post in Calypso. :( In that thread, Andrew Ozz mentioned it was theme specific. Do we know which theme that was?

    I know that we have had issues here with the slideshow autostart parameter before. (Ref: https://en.forums.wordpress.com/topic/gallery-slideshow-autostart?replies=3 )

    Is there any other suggestion we can give @goodgoodscience?

    Thanks again.

    #3067579

    My best suggestion is to not leave the text editor. I was able to make the “false” parameter stick and work correctly if I published the post directly from the text editor without switching back to the visual editor. (That’s a long sentence)…

    I’ve reopened the issue and added my experience. I’m hoping to hear something soon :fingers crossed:

    #3067632

    justjennifer
    Moderator

    @lizkarkoski-Thanks again.

    @goodgoodscience If cancelling the slideshow autostart is something you’d like to do on your slideshows, then:
    1. After you’ve inserted your slideshow in your post or page and save/update, at the top right of the Editor you’ll see another tab to HTML next to “Visual” which when clicked will open the HTML Editor.

    2. Look for your gallery slideshow shortcode. It will look something like [gallery ids="163,162,161,160,159,158" type="slideshow"]

    3. To that shortcode add the following parameter: autostart=”false” so the entire shortcode reads like:
    [gallery ids="163,162,161,160,159,158" type="slideshow" autostart="false"] (Note there is a space between each parameter.)

    4. Publish/update your post or page without leaving the Text Editor.

    5. Close the editing window.

    Again, adding the autostart=”false” parameter prevents the slideshow from auto-starting and advancing. Visitors will need to advance the slideshow manually.

    Hope that helps but let us know if you have any other question about this.

    #3067660

    Yep, no problem. I’ll be back once I have more news.

    #3067755

    @justjennifer – Thanks for the information on manually advancing the slideshow. I am not sure if that’s something we would like to do but I’m glad to have the instructions.

    #3067783

    justjennifer
    Moderator

    You’re welcome, @goodgoodscience. :)

    @lizkarkoski – Do I understand that this bug was marked fixed or is waiting to be fixed in WP core’s next update? Thanks for keeping us updated. <3

    #3067788

    Good morning –

    Yes, it looks like it’s on target for 4.9.3.

    #3067798

    justjennifer
    Moderator

    Hello, just coming back to report that there’s been no change in behavior when moving between the HTML Editor and Visual Editor after adding the autostart parameter in the HTML Editor. Additional code is still inserted in the gallery shortcode. (temp screenshot)

    Again the post was created in Calypso post editor.

    #3067799

    Thank you, justjennifer.

The topic ‘Change speed of slide show in Dara theme’ is closed to new replies.