Changes being reverted automatically

  • Author
    Posts
  • #2216916

    I have inserted a page jump on several pages, saved the page, viewed the page to verify that the page jump is working; however as soon as I go back to edit the page, iff I switch between visual and text editing of the page, the code for the page jump is replaced by a line jump.

    This happens with all new page jumps I add and is really annoying as the only work around is to re-insert the page jumps every single time I edit a page!

    Any help with this glitch would be very much appreciated. At this point I’m looking for a different website host because I’m finding WordPress very difficult to control consistently.

    The blog I need help with is jacobbeaudry.wordpress.com.

    #2217019

    timethief
    Member

    The page jump links will not display in Preview mode. They will be there when the post is published, provided you entered them correctly.

    I find this post http://wpbtips.wordpress.com/2010/08/01/links-to-specific-points-on-a-page/ more helpful than the support doc at http://en.support.wordpress.com/splitting-content/page-jumps/

    #2217020

    timethief
    Member

    This happens with all new page jumps I add and is really annoying as the only work around is to re-insert the page jumps every single time I edit a page!

    Okay now I have reconsidered and that definitely should not be happening. I tagged this thread for Staff assistance. Please subscribe to it so you are notified when they respond. To subscribe look in the sidebar of this thread, find the subscribe to topics link and click it.

    #2217023

    Thank you for having a closer look. The issue was not related to previewing. The jump can be published and working; however any future edit will remove the jump from my code.

    I am subscribed and keen to resolve the problem!

    Best,

    RA

    #2217024

    timethief
    Member

    You are welcome. All you need now is patience while waiting for Staff to work their way forward to this thread.

    #2217223

    lizthefair
    Staff

    @mcgillcalhelp

    I’m happy to look into this for you.

    I see a jump on this page to your contact form.

    https://jacobbeaudry.wordpress.com/about/tutorials/#FORM

    It looks like the way you created the jump was to add this line of code to it’s own paragraph between your testimonials and the form.

    <a id="FORM"></a>

    I wasn’t able to replicate the problem behavior, but you might have better luck if you add the id to a line that has other content. For example, you already have this line at the top of your contact form:

    <h2 style="text-align: left;">Want to join a group? Have questions? Get in touch!</h2>

    You can add the id to the exiting code like this:

    <h2 id="FORM;" style="text-align: left;" >Want to join a group? Have questions? Get in touch!</h2>

    and that should be more stable.

    Let me know if you continue to have trouble, and I’ll be happy to help.

    #2217266

    That has helped with some but not all of the jumps. e.g. the Math 133 page I can’t get it to work for the life of me for the “About weeklies” or “costs/payments” links. Now it’s saving them (though it still sometimes deletes them without my doing anything); however it just doesn’t jump.

    I really don’t understand what the issue is because most of the code is just copied – by wordpress – from page to page! Please let me know if I can provide a screencast or shots that show this happening, I’d be happy to do so if it can help resolve the issue!

    Best,

    RA

    #2217270

    lizthefair
    Staff

    e.g. the Math 133 page I can’t get it to work for the life of me for the “About weeklies” or “costs/payments” links. Now it’s saving them (though it still sometimes deletes them without my doing anything); however it just doesn’t jump.

    This was my fault. I told you to include the semicolon inside the quotations marks in the ID section and that was a mistake. I removed the semicolons for those two jumps and now they work.

    So to repeat the example from before the correct code is

    <h2 id="FORM" style="text-align: left;" >Want to join a group? Have questions? Get in touch!</h2>

    Please let me know if I can provide a screencast or shots that show this happening,

    This would be really helpful. If you just save the screenshots to your media library I’ll be able to see them there. If you can take a screencast and send me a link to it, that would be even better.

    #2217271

    Ok – thank you. I thought the semi-colon was weird and had tried moving it in and out of quotations; I guess the other places I used the code, there weren’t other specifications, so I didn’t think to include the semicolon.

    I’m done working on the page for today; however I’ll be back at it tomorrow and will definitely make a screen cast if the any variation of the issue persists. Did you want me to show the original issue of it automatically reverting if I switch between views, even if it the jump was operative from a *previous* edit?

    Finally – I’ve been having consistent issues with an “n” appearing in the upcoming events widget that I can’t resolve. I’ve posted several times in the forums and searched both the site and the internet, but to no avail. Is there any way to get a staff member to look at the issue? I had hoped the CSS upgrade would give me some control over it, but nothing there, either.

    thank you kindly for your help!

    best,

    RA

    #2217272

    lizthefair
    Staff

    Did you want me to show the original issue of it automatically reverting if I switch between views, even if it the jump was operative from a *previous* edit?

    That would be great. Any example you have of the strange behavior is useful.

    Finally – I’ve been having consistent issues with an “n” appearing in the upcoming events widget that I can’t resolve.

    I see what you mean in the widget, but since the data is being pulled from your icloud calendar it’s hard for me to see what’s going on. Is that calendar published anywhere else? If I could see more data I’d be in a better position to help you out.

    You might also find a clue on Apple’s iCal support page:

    http://support.apple.com/en-us/TS4337

The topic ‘Changes being reverted automatically’ is closed to new replies.