Changing color of lettering on cover photo.

  • Author
    Posts
  • #3353644

    Hi!
    I changed the color of the lettering on my cover photo from standard black to white. Looks good in the editor – but then it changes to back to black whenever I preview/publish. Why? How can I get the lettering to stay white also outside the editor mode?
    Thank you in advance,
    Maria

    The blog I need help with is dinnerdebateclub.wordpress.com.

    #3353948

    musicdoc1
    Member

    Hi Maria,

    Can you provide a link to the page or post that you’re referring to? I don’t find any images displayed on the homepage of the site https://dinnerdebateclub.wordpress.com/.

    doc

    #3353989

    Hi! I’m so happy to hear from you! The link looks right. You probably couldn’t see anything because I had unpublished it. It is published again now.
    Can you see it?
    Kind regards,
    Maria

    #3354036

    macmanx
    Staff

    Without a paid Premium plan, Custom Colors is only available for preview: https://en.support.wordpress.com/custom-design/custom-colors/

    #3354037

    I see. Thanks for your help!
    /Maria

    #3354057

    musicdoc1
    Member

    @macmanx,

    On my test site with Sophisticated Business applied, I set a static front page with a cover image using the cover image block. Now I have almost no experience with the block editor, but in my tests I found that text, as a heading, inserted over the cover image is white by default (the color that Maria wants). Not only that, but I was unable to change the color of the text, or discover a way to move the heading down to the bottom of the image as hers appears.

    #3354063

    musicdoc1
    Member

    Clarification:

    Apparently I’ve been writing the title over the cover image using a Heading Block, which opens automatically whenever I add a cover image with the Cover Block. I didn’t know that it was a separate block previously.

    unable to change the color of the text
    I see inline code and HTML as options now for the heading block, but haven’t tried changing the color of the text with those.

    #3354070

    macmanx
    Staff

    Ahhh, on a Cover block, I’m sorry, I misunderstood that.

    @dinnerdebateclub in a Cover block the text does default to white, and you should be able to change it.

    What I find interesting here, if I insert a Cover block under Sophisticated Business on the front page, it gives me a Paragraph block for the text, not a Heading block.

    If I enter “Testing?” and set the text color to white, it works: https://cld.wthms.co/bXA8Fh

    Now, if I switch that a Heading block, and again make sure the text color is set to white, it also works: https://cld.wthms.co/9MLfvQ

    That last one is duplicating the settings on your page and block, so I’m not entirely sure why it isn’t working for you.

    When things go wrong to this agree, I usually like to delete the block and just create it again. Would you please try that?

    • This reply was modified 1 month by  macmanx. Reason: fixed second screenshot link
    #3354078

    Well, this is good news! That the default is white! Then there is hope. I think you are right about starting over. I have probably confused the system by experimenting too much. Like wanting to move the header on the cover photo down several times.

    I tried creating a new block for the text, but it does the same thing for me. White in edit mode. Black in preview and live. Maybe I have to start completely over with everything. From scratch. And make sure I do not change anything.

    Can I ask another thing? The email contact form did not work for me. (I tested it several times in edit mode. Is this a common problem? Is there something one should/could do to make it work? I just deleted it now and simply inserted a mail address. That feels safer.

    Thank you sooooooo much for your help!!

    #3354082

    musicdoc1
    Member

    @macmanx,

    What I find interesting here, if I insert a Cover block under Sophisticated Business on the front page, it gives me a Paragraph block for the text, not a Heading block.

    Sorry, I misidentified the block. They’re all new to me. It is a Paragraph block in my tests as well. : -)

    #3354084

    musicdoc1
    Member

    If I enter “Testing?” and set the text color to white, it works: https://cld.wthms.co/bXA8Fh

    I’m still not find any text color options. Have looked through in the additional options under the “More Rich Text Controls” and “More Options” buttons.

    #3354129

    kokkieh
    Staff

    @dinnerdebateclub

    Can I ask another thing? The email contact form did not work for me. (I tested it several times in edit mode.

    The form submitted your test messages just fine. You can see them here:

    https://dinnerdebateclub.wordpress.com/wp-admin/edit.php?post_type=feedback

    If the emails didn’t arrive in your inbox, it means Gmail has likely filtered them as spam, or perhaps into the Social or Updates folders instead.

    By the way, I think you might have a spelling mistake in the email address you currently have on your site.

    @musicdoc1

    I’m still not find any text color options. Have looked through in the additional options under the “More Rich Text Controls” and “More Options” buttons.

    Color options are not in the formatting pop-up toolbar. They’re in the sidebar under the Block tab.

    https://cloudup.com/cJiW7B22Ggb

    #3354147

    Aaaaaaah! Thank you. More good news! :) I don’t care so much about having requests for more info forwarded to gmail. Maybe even better to have them on the website. I just don’t want them to be lost.

    And thanks for pointing out the typo too! :)

    #3354150

    kokkieh
    Staff

    Happy to help :)

    #3354173

    musicdoc1
    Member

    @kokkieh,

    Thanks, cap’n. : -)

You must be logged in to reply to this topic.