Need help? Check out our Support site, then


changing colour of links to traditional blue without CSS?

  1. I wish to change the colour of all my links from green to traditional blue.
    All your answers give CSS which I neither understand nor can use in wordpress.com which does not allow it. There must be some other way.

    The blog I need help with is torahtextmakesenseofit.wordpress.com.

  2. Hi there,

    Unless your theme offers the option to set a colour for links, the only way to do this is via custom CSS. You can set the text colour for linked text by using the font colour button in the editor toolbar, or via inline CSS, but the hover colour for a link cannot be set that way.

  3. Thank you. I had tried to put the colour code in the HTML but apparently put it in the wrong place, so it did not work.
    I tried your way of putting the colour in the editor toolbar and it works. I have kept the HTML for reference.
    The trouble is that the visual editor does damage to my format, so I have to use only codes in the HTML editor, and as yet the HTML editor toolbar is iincomplete and does not have the colour thing. Please confirm this and that it is not a fault in my site.
    Please also confirm if you are working on extending the toolbar in the HTML editor.
    At least it works, I will find out how to do it in HTML from the sample, and at last have a solution. I am not interested in, and do not care about, the hover colour. For this my greatest thanks to you.

  4. However, while it works with media links it does not work with URL links.
    There the visual editor changes the colour to blue, but when I view the page it is still green. Must I enclose the URL in something?
    With media links I can now do it in the HTML, no problem.

  5. The HTML editor toolbar does not have colour options, no, and there also aren't any plans to add it there. The HTML editor toolbar only contains the most basic formatting options.

    What exactly do you mean that the visual editor does damage to your format? Switching between editors will strip out any disallowed or incorrect code, but it shouldn't otherwise make changes. Can you please provide a sample of before and after HTML where I can see how it changes? You can use the Code button here in the forums to paste in HTML without it being rendered.

    It would also help if you can provide a screen recording of what happens. You can upload it to a service like snag.gy or cloudup.com so I can see it.

    There the visual editor changes the colour to blue, but when I view the page it is still green.

    Can you please give me a link to a post/page where you've tried to change the colour this way?

  6. Thank you for your letter.
    There are two issues: the colour of the links, and the damage done by the editor.
    Let me deal with the colour first.
    There are three tyres of link:
    1. A media link to a PDF or JPG or PNG. These to me are the important ones, and your reply works, excellent. I simply add a certain string after the <a and space, and it works fine.
    2. A hidden link to a URL, e.g. if i write "Click HERE" and the word "HERE" is connected by a link that the viewer does not see to a URL (i.e. by clicking on HERE he goes to the URL address) which may be another page or somewhere else on the internet. Here too it works exactly the same, excellent.
    3. Rarely I have put in a direct URL link, either to another site of mine or to someone else's' e.g.
    http://www.xyzrubbish.com
    In these links, if I go to the visual editor (I tried it on a safe page) and block the URL and press the colour button (as with the others), the URL immediately changes its colour to blue IN THE VISUAL EDITOR. But when I press "update" and "view page", the URL is still green. I can then go backwards and forwards between the page and the editor. The URL remains blue in the editor and green on the page!
    [Sorry to be so long-winded but I do not know the correct technical terms that would shorten this.explanation.]
    Actually this is not so serious because whatever the colour the reader can see it is a link. With the other two types (which you have solved for me) they could not always spot it. and I am grateful for the solution.

    If you want a link to a page where I have tried this (on a test page and then transferred the HTML but this happens on the test page) try the home page of my site
    http://www.torahtextmakesenseofit.wordpress.com
    where you will see where (on the home page and the site map page) I have successfully changed the earlier types of link to blue but not the www. links to my other sites or to other peoples'.(I have not yet had time to do the rest of the site.)
    ============================
    Regarding the visual editor, here is the problem.
    WordPress believe that everyone should do things the way Americans do, but many do not want to.
    American paragraphing is unjustified, no indent and a blank line between paragraphs.
    I want traditional paragraphing, justified (there are no problems here), with the first line indented and NO blank lines between paragraphs except where specially wanted between groups of paragraphs.
    (1) I can get out of the blank line in most cases and start a new line without one, in the HTML editor, but not in the visual.
    It is important not to use <p> or <div> there as these will give a blank line.
    (2) For the indent I use <span style="padding-left:5%;"></span>. There are possible variants, e.g. text-indent, em, px &c. but as long as I use <span> and not <p> or <div> for this it works. I do it in the HTML editor, "update", "view page" and all is excellent.
    HOWEVER, if at any time later I accidentally by mistake happen to enter the visual editor and DO NOTHING, just realise I made a mistake, and leave without updating even, the indents all disappear and cannot be recovered. They are no longer on the page, or in the HTML, and have to be re-inserted, the visual editor has interfered un-asked and destroyed my page which has to be re-formatted. There are nineteen or twenty indents on my home page!
    I do not understand how to send you a screenshot, I can do one in JPG or PNG but do not understand how to send it escept by e-mail. However from what I have described above it should not be necessary.
    I thank you for your interest and hope you can solve the problems, the colour one probably but I doubt if you can sort out the editor.
    Thanks, Biblicon (or Halilac)

  7. In these links, if I go to the visual editor (I tried it on a safe page) and block the URL and press the colour button (as with the others), the URL immediately changes its colour to blue IN THE VISUAL EDITOR. But when I press "update" and "view page", the URL is still green. I can then go backwards and forwards between the page and the editor. The URL remains blue in the editor and green on the page!

    Okay. So if you connect the link to text or a media file, we add HTML in the editor that can be styled and which allows you to change the colour. If you just paste the URL directly, we only add the HTML at the moment your page loads, and that will always use the styling set by your theme.

    To get around this, paste in your link, highlight it, click the link button, and paste the link again, so treat it as if you're adding a hidden link, as you call it. That way the HTML will be added behind the scenes, and colour changes should stick.

    American paragraphing is unjustified, no indent and a blank line between paragraphs. I want traditional paragraphing, justified (there are no problems here), with the first line indented and NO blank lines between paragraphs except where specially wanted between groups of paragraphs.

    Actually this is not a case of how America does it, but has to do with web standards. Online publishing has its very own style rules, which differs from both British and US style rules for print publishing. These style rules are built into HTML tags, that's why adding a specific tag will always get a specific result. But I get your point. I'm South African, by the way :)

    (1) I can get out of the blank line in most cases and start a new line without one, in the HTML editor, but not in the visual.

    To create a new line without a blank line inbetween, press Ctr-Enter when going to a new line, instead of just Enter. In HTML that enters a line break instead of a paragraph break, meaning it doesn't create a new p-tag which adds the blank line automatically.

    (2) For the indent I use <span style="padding-left:5%;"></span>. There are possible variants, e.g. text-indent, em, px &c. but as long as I use <span> and not <p> or <div> for this it works. I do it in the HTML editor, "update", "view page" and all is excellent.

    text-indent is actually the accepted way to indent text in HTML, but that will require each paragraph to be in its own set of p-tags, which you don't want. I'm pointing this out so you can understand you're using the HTML code in a way it wasn't designed for, which can have unforeseen effects.

    The editor is programmed to remove any HTML it sees as invalid, in order to prevent errors. While what you're doing is...unorthodox for want of a better word, I don't really think your code is invalid, though, so let's dig a bit deeper.

    Are you using the WP-Admin editor, or the one in My Sites ->Blog Posts? And can you please give me a link to a post on your site that is currently formatted as you describe, with the indented paragraphs?

  8. Thanks for reply.
    Line-break tends to justify the last line, so if you have two words, one comes at the beginning of the line and the other at the end. This is not what I want, but my way round it works so I am not worried.
    I see no reason why webs need to have style rules, but still, that is not up to you.
    I am not using the wp-admin editor, I have heard of this but never found it! I have found wp-admin but no editor there!
    I am not using the My-sites/page editor (though I found it and used it once) but see no advantage.
    I go to my page, find the word EDIT and click on it. Sometimes a symbol comes up in the bottom right corner, when I hover it say edit, and I use that as quicker.
    You will find the indents on the home page of my site
    http://www.torahtextmakesenseofit.wordpress.com.

    Meanwhile I will try your idea of a link within a link and let you know. I am pressed at the moment. As we are talking about a direct URL link it first comes up automatically and will try this in a further link _ I get your point.
    I am glad you are from S. Africa, I am originally from England, I had already noticed that you spelt colour correctly! Hence you saw my point. An American would not!
    Thanks again,

  9. I tried the link within a link and it works.Blue. The http// or https// does not appear, it starts with www. but that does not matter at all, it is recognised as a link and works as such, and nobody cares about the http when reading my site.
    I very much appreciate your help, and hope you can sort out the editor, though I doubt it. Someone told me there is a solution with a plug-in but as wordpress.com does not support plug-ins I have not investigated.
    Incidentally it was a South African friend who first introduced me to HTML and helped when I started to build the site, but he could not help with the problems I gave you.

  10. I go to my page, find the word EDIT and click on it.

    That is the My Sites editor. If you click on My Sites ->Blog Posts ->Add/Edit you'll get exactly the same screen.

    For the WP-Admin editor, go to the WP-Admin dashboard, and click on Posts.

    I had already noticed that you spelt colour correctly! Hence you saw my point. An American would not!

    Haha. You realise, of course, that the majority of my colleagues would say we're spelling it incorrectly :D

    I will take a look at that page over the weekend and see if I can replicate the issue with indentation disappearing. I can't guarantee it's something we'll be able to fix, but I'll do my best.

  11. Okay, I think I've figured out why the editor keeps stripping out the span-tag you use for the indent.

    I looked at your page in the editor, but already I didn't see the span tags there, but if I viewed the page source in a browser I saw:

    <span style="padding-left:5%;"></span>

    With the paragraph then following that. The span tag is being stripped because there isn't actually anything inside it. I'm amazed it gives you the desired effect of indenting the text at all - if anything that is the bug, and not that it's being deleted. Span-tags need to have something inside them for them to function properly.

    If that's not how you added it, please copy a paragraph for me the way you added it. Use the Code button here in the forums to paste it in so I can see the actual code.

  12. I have just seen your reply, extremely interesting , just before going to bed here, so will answer one thing quickly and the rest tomorrow when I have time to go into it.
    Yes, what you showed is exactly what I put in. Tomorrow, meanwhile thanks..

  13. [1]. I have experimented, it is as you say.

    [ Today I looked at the site first page and the indents had gone!- I must have entered the visual some time, which is why you did not see them. But the code you saw correctly. I reinserted the page from a back-up.
    I understand your explanation. It is something like BOLDbold (i.e. bold on, bold off) in a word processor, which you can delete on editing, but here the editor deletes it automatically.]

    The solution is now clear. If I insert a space, that too is removed, BUT if I insert a HARD SPACE (&nbsp:) the editor does not delete it or the indent. (The actual code for a hard space always disappears from the HTML editor for some reason, but the space it creates remains on the page, even after entering the visual editor.) So I must insert a hard space between the span command and the </span> command and Hey Presto!. This increases the indent by an infinitesimal amount which of course does not matter at all.
    Very many thanks.

    2] Regarding the HTML toolbar, I see the problem of increasing it, e.g. to add colours or alignment involves commands (tags) etc., but one very important one does not. Can you get them to add to the toolbar "special characters" which merely inserts a character and would help a lot? No need to reply, if I see it one day you have my thanks in advance.

    3] While I am on, I back up my pages by saving the entire HTML (of each page separately) in an RTF unicode file, which works. Is there any way to back up the media library in case of general failure?

    4] For information only. I work in English on one site, in Hebrew on another, and mixed on a third. Hebrew is RTL (right-to-left) apart from a different alphabet. I have overcome the basic problems, there are different ways and I have chosen the one I like best.
    However, there are two major problems which you have possibly not encountered, I have understood both, but both are outside your sphere, one caused by Microsoft and the other by Google. One I have to put up with, the other Ihave found a solution which is far from satisfactory but better than nothing. If you are interested, I will send you the details (problems and explanations )that may help you or your colleagues if someone asks, for information only, I require no action. Let me know.

    Thanks again.

  14. If I insert a space, that too is removed, BUT if I insert a HARD SPACE (&nbsp:) the editor does not delete it or the indent.

    Excellent! Great job figuring that out.

    Can you get them to add to the toolbar "special characters"

    I'll put in a feature request, but I can't make any promises as to if and when it might be added.

    I back up my pages by saving the entire HTML (of each page separately) in an RTF unicode file, which works. Is there any way to back up the media library in case of general failure?

    There is no way to back up/export the entire media library, no. But we keep multiple backups of your site in the unlikely event that all our servers were to fail. Just don't delete any media files from your site - we don't restore backups in cases where you delete your own content.

    If you are interested, I will send you the details (problems and explanations )that may help you or your colleagues if someone asks

    It would be great if you could post a short description of the issue and how you solved it here, thanks. These forums are also indexed by Google, so it would be discoverable by anyone searching for an answer on the same question.

  15. Thank you again for all your help.
    With this we can close the matter as successfully solved.
    I am putting the problems of RTL on a separate letter so that it can be passed on without irrelevancies.
    Just incidentally, I read your profile etc. I visited South Africa only once, for two days, that was 69 years ago when I was 18, long before your time. On the ship on the way home I learned to sing Sarie Marais in Afrikaans, the only Afrikaans I ever learned, and still remember the tune and all the words!
    My parents spent 15 years there before returning to England, 7 in Muizenberg and 8 in Claremont, Cape Town, but they never learned Sarie Marais!
    Bye and all the best.

  16. Arabic and Hebrew (the West-Asian languages) are written from right to left, and in computers, programming, HTML etc., this is abbreviated to RTL or R2L, others in contrasr referred to as LTR or L2R (not necessarily in capital letters). This presents special problems, particularly on a web site, quite apart from alphabet, punctuation marks, diacriticals, and in Arabic letter changes.
    My knowledge of Arabic is almost nil, but I am familiar with Hebrew, and all problems in Hebrew (with the exception of numbers 15,16 when Hebrew characters are used) occur in Arabic. The reverse is not true.

    There are three ways of dealing with Hebrew in WordPress:
    (a) To take a Hebrew version (exists in the .org but not in the com., to the best of my knowledge. This gives a Hebrew interface which not everyone wants,.
    (b) The ordinary version, setting the language as Hebrew. Also a Hebrew interface with a non-changeable ugly footnote on each page.
    (c) Set the language as English, but start off with the HTML command
    <div dir="rtl"> with </div> at the end.
    You may wish to switch from time to time, or you may wish to simply insert Hebrew word(s) inside English text, the latter not needing div..
    The same problems will arise with all of these. Here are two major inherent problems I encountered, after the programmers claim to have solved them all.

    1] Early DOS programmes, such as Word Perfect 5.1 which I still use today, generally provided Hebrew support without problems. When Windows came along they decided on a new system for Hebrew support which included some lunatic features. Numbers are treated as English, which is changed automatically, and with them hyphens but not spaces, which change backwards and forwards. For instance a telephone number 123 456 (note the space) will appear as
    456 123! Brackets appear reversed and in the wrong place, and so on.
    The Web has basically inherited all this. It is possible to insert Hebrew words by simply changing the language and direction on the keyboard, but in HTML editing the codes are all in English and you have to keep changing. This is annoying, inherent but has to be put up with. However the Hebrew cannot always be edited. Also the punctuation marks come out wrong., brackets are (not always) reversed, but far worse is the fact that when you insert ditto marks (") so-called quotes, these appear alright in the codes but are automatically changed to full quotation marks (66 and 99) in text -- and in Hebrew they come back-to-front, which looks ridiculous. If you switch them they change back again!
    A solution to this is not to use quotes in Hebrew but instead to use the special symbol for inches/seconds, which is near enough.
    Altogether there is little that can be done, allowing for the Windows lunacies.

    A further problem in WordPress iis in inserting diacriticals. This can be done in a badly designed Windows programme such as MS-Word with great difficulty, but when this si tried in WordPress - well, it works but all the diacriticals appear together on the first letter of the word! The solution here is to write the word(s) with the diacriticals i, say, MS-Word, then copy/paste it in its entirety into the web editor. It seems to work.

    2] When doing mixed text (ltr and rtl) or parallel columns, you will carefully choose your fonts: typefaces that you like, and sizes that match. The default sizes do not match, so you have to make either the English or the Hebrew bigger or smaller till you get a matching size. This cane be done easily in HTML.
    When I did this, working in Opera, I had complaints from friends that words in one language were enormous or tiny alongside words in the other. I found out that the problem was the browser. What I did in Opera came out alright in Firefox, but not in Chrome, which most people use and which messed up the fonts completely. It changed both the typeface (their Hebrew looked terrible) and the size, parallel columns did not match in length and inserted words or numbers of one language in the other were either dwarfs or giants next to their neighbours,. This messed up my site completely.
    A not-to-good solution for a static site that I found was to set out each page in Opera, take screenshots into One Note, copy/paste them into a graphics programme, save them as PNG and insert them onto the web page as images replacing the original.s. This way the page appeared as an image and Chrome could not mess it up.
    It solved the problem at a price. The text, now part of an image, could not be edited or changed or updated, spelling mistakes could not be corrected. Furthermore, nothing could be searched, and in particular the search engines could not find anything. The problem is caused by Google (Chrome) and will remain until they repair Chrome so that it copies fonts (in typeface and size) and does not mess things up. (Initially Firefox did the same, but it has been fixed. A new browser Avast, by the anti-virus people, also does NOT mess it up, but causes other trouble in editing.)
    If you find the problem you can do the same, but be prepared to pay the price.

    There are of course other problems with rtl, but for these you can work out the solutions yourself. The two I quoted are inhrerent.

    END

  17. Thanks for this info. We're working on ways to make WordPress.com handle RTL languages more gracefully, but it is a pretty complex issue so a fix won't come quickly.

    Sarie Marais is a pretty memorable tune :)

Topic Closed

This topic has been closed to new replies.

About this Topic