Need help? Check out our Support site, then

Comment function requires me to use different email address

  1. When I am on a wordpress site and clearly logged in as me (in the top right hand corner), and try to comment on someone else's blog, I always get taken to a new page. That page tells me I am trying to post a comment under an email address that I no longer use, and haven't used for a long time. It tries to force me to enter the password that must have been associated with that account a long time ago. It also doesn't allow me to log in under the email address I am actually using. The page just refreshes with an error message asking me to give the password for the old account. I have no problems posting comments in Reader, (so have had to follow my own blog to reply to comments there), but this happens when I am in the blog site proper. I have some screenshots of this, but can't see a way to upload them.

    The blog I need help with is

  2. This is all going to boil down to how many username accounts you have and exactly which one registered which blog. There is only one means of account recovery so please read on.

    You must be logged in as Admin under the exact same username account that registered the blog to access the blog's dashboard.

    Clicking this link should display all your blogs registered under the same username, including the hidden ones:

    If you do not see the blog here then
    follow this guide >

    If you have lost your log-in information you can visit

    If required please complete the form for account recovery at this link and submit it to the Account Recovery Staff so they can contact you by email ie. not on these public support forums which are available to everyone with internet access.

  3. Hi Timethief,

    The email address I want to use is definitely the administrator of my blog. But even when I am clearly logged in under this email address, the comment function wants to post under an old email address I no longer use.
    I definitely do not want to recover this second, old address. I want to delete this old address, or at least completely disassociate it with my current address which is also the blog administration address.

  4. If I could post a photo here, I could show what I mean. At the top of the page, I'm logged in as administrator under my current address. At the bottom of the page, any comment I want to make is pre-completed with a totally different, no longer relevant, email address. And wordpress won't let me override this and use the current account.

  5. This issue is still occurring! I am logged in as me, I comment as me, then i get thrown to a different page, asking me to log in with old, no longer used credentials. It gets stuck in a loop and does NOT let me post the comment under the correct user email address!

  6. I'll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    Yes, please post a screenshot. You can use to share screenshots. Or you can use the guide I linked to and upload it to your Media Library, and return to this thread to provide the file name so Staff can examine it.

  7. shawnajroberts

    Hi there!

    If you could provide a screenshot via timethief's instructions that would be really helpful.

    Can you also try clearing your browser's cache and cookies? Here's a guide:

    Can you tell me what the old email address you're seeing appear? Email addresses are redacted from the public forums, so only I and other staff members will be able to see it.

  8. the old email address is [email redacted]. trying to figure out where to load the screenshots.

  9. OK, this screenshot shows me logged in to my current account, definitely under the correct email address:

    Then this image shows the super-annoying thing that happens once I try to post that comment. I get taken to another page, pre-completed with the old address. I am not logged in to the old address email account on the computer, either.

  10. You can use to share screenshots and then post the link in this thread. Or you can use the guide here and upload it to your Media Library, and return to this thread to provide the file name so Staff can examine it.

  11. shawnajroberts

    Thanks for the screenshots! Can you try clearing your cache and cookies as described here:

    Let me know if that works.

  12. OK! I had previously done this but chosen "last 4 weeks". Tried again with "from beginning of time" and it worked! Thank you! :)

  13. shawnajroberts

    Oh perfect. :)

    Let me know if I can help with anything else.

Topic Closed

This topic has been closed to new replies.

About this Topic