commenting bugs

  • Author
    Posts
  • #849997

    roaring40
    Member

    You have a bigger problem that you think regarding the new comments policy. Yes you have fixed the few bugs. But you have yet to see that WordPress is picking up on the blogroll mail addresses and calling it theirs and requiring those that have never had any a/c whatsoever with wordpress or any other ancillary or subset thereof.
    Further, the option of passive comment has been removed and I can find no box to tick that will return it.

    And as I’m at it, I really dislike the notion you want me to ‘submit’ to you for anything. Why not have the manners to put ‘publish’ somewhat less servile in tone.

    #850093

    tandava108
    Member

    You will submit …. resistance is futile ;-)

    #850096

    nandobase
    Member

    Matt rules…. lol

    #850097

    That want to make sure that those that actually do comment are seriously compelled to comment and are willing to jump through flaming hoops after being doused in gasoline. Those are the only legitimate commenters.

    #850129

    nandobase
    Member

    CheckMatt…. I mean… Mate…..

    #850277

    We’re continuously updating WordPress.com and everyone at our company is working with the goal to make the best blogging platform out there. Sometimes we make mistakes! And not everyone agrees with every decision. :) When those things happen, we’re around to fix the bugs and we appreciate so much when you let us know about them in a helpful way.

    Further, the option of passive comment has been removed and I can find no box to tick that will return it.

    What has been changed so far is that if you use an email address that is present in WordPress.com and may have someone’s online identity associated with it, then you must log in before you can comment using that email address. So, you can actually still leave anonymous comments if you use an email address not present in the WordPress.com system. The idea is to try to help prevent impersonation of people with existing online identities at WordPress.com or Gravatar.com.

    The landing page when you try to use an email present in the WordPress.com or Gravatar.com system to comment is not pretty right now, and it needs some work. Our developers were asked to make the change fast, and so the first step to update it was taken and now we’ll work together with them to make it better.

    Online impersonation has been a recent concern for many of our users. Hopefully those users will appreciate these types of updates and chime in with helpful feedback about making it better.

    I’ll see what I can do to keep you updated in the forums with progress on this issue.

    #850278

    I can’t tel you how much I HATE this change, and I don’t even have a WordPress.com blog! (Mine is self-hosted.) But I do like to comment on others’ blogs, not only to participate in their community, but in hopes that others will click my name and visit mine. But now I have to log in with Twitter or Facebook, or WP – and none of those show my proper name or website link! I don’t want people to go to my Twitter page, or worse, one of the other WP.com blogs I’m linked to! If we must log in, PLEASE at least give us a means to choose the name and website (inlcuding non-WP.com sites) we want to display!

    #850279

    nandobase
    Member

    I have an idea. Instead of using the email of the gravatar, we should be able to use the password of the gravatar. That way, only the gravatar owner can use it. And then we may freely choose the blog urls linking to our usernames.
    Off course the blog admin should not be able to see the commenters passwords one way or the other.
    Just a noobish idea. :)

    #850280

    Yes to nandobase’s idea! Also I want to add, logging in with a different email address isn’t a solution for me, because I want my picture to show up when I comment, not one of the generic gravatars.

    #850282

    nandobase
    Member

    @jennettemariepowell, you can easily change your website link.
    Go to your wp.com dashboard > users > personal settings > account details.
    you’ll find your website box right there. Change the url.

    #850283

    @jennettemariepowell, good feedback! You can do what you’re asking. The difference is that if you want to use your email address with your Gravatar attached, now you must log in first. You can still fill in the link you want after that. I think the trouble is that it’s just not easy to see that option during the first login step (we should fix that). Try this:

    1. Log in at WordPress.com
    2. Open a comment form on a WordPress.com blog
    3. Fill in your WordPress.com email and whatever link you want for the comment
    * Let me know if you have any trouble with that. I just tested it and it worked for me, so if you have any trouble, let me know your steps.

    @nandobase, WordPress.com and Gravatar.com accounts are the same, once you log in to either one you’ll be able to comment.

    Also, here’s a thread which you can refer to for future updates: https://en.forums.wordpress.com/topic/recent-update-to-commenting?replies=1

    #850286

    listlessink
    Member

    Many of my readers self-host and have gravatar accounts but do not actually care that much for a wordpress.com account. After all, why would they? They self-host so they don’t have to deal with these pleasant features graciously and forcibly given to us every so often.

    This is totally in line with your design philosophy of keeping reader experience as simple and as intuitive as possible. Now, they have to create an account, change the link from the default wordpress.com site, and log-in everytime they want to comment. But wait, it gets better. No one ever told them they need to do all of that. Instead, they get an error, lose their comments, and understandably leave frustrated. ^ ^

    p.s. I know for a fact that at least a few regular commenters have left my blog (via tweets directly telling me that they’re frustrated at all the lost comments and they’re done. They are “not going to give a f***” anymore.)

    I guess, in a way, this is super super effective in solving impersonation. Now there’s no one to impersonate. :) Happiness, engineered!

    p.s. I would threaten to leave, but I can’t unfortunately. I’ve spent too much time on my blog to just drop it or move to another platform. I think back on that little survey I did a while ago–the one prompted every so often when I log in to my wordpress.com dashboard–and I kind of wish I could change some of those answers. WordPress used to be so lovely and in touch with its bloggers.

    #850287

    listlessink
    Member

    Our developers were asked to make the change fast, and so the first step to update it was taken and now we’ll work together with them to make it better.

    What was the huge huge rush that you couldn’t work out the kinks first before implementation? Did you guys uncover a plan to mass impersonate wordpress.com/gravatar accounts in blog comments in mid-March and must deal with it… fast?

    #850288

    roaring40
    Member

    @ Designsimply
    I am sympathetic to the security problems, hacking and spam is no fun. But an explanation on that page might have gone a long way to mitigate any ire people feel at being required to find a inactive a/c, or place a clean email on the comment form.
    Further, putting one of those ‘captcha’ thingy’s would have achieved exactly the same result without any of this unholy hassle.

    #850298

    @designsimply,

    Firefox 11.0 Mac not logged in to WP or gravatar.

    1. Enter email address and name and web address are filled in.

    2. Add comment and click the submit button.

    3. Warning comes up that I have to log in and tells me to click the back button.

    4. Back button takes me back to the page with the comment form on it, and I have to look around to find out how to log in. See the tiny WP, fb and twitter icons and click the WP icon.

    5. Enter my username, but login form does not fill in my password for me and since I have very strong passwords that I cannot remember, I have to open my keychain, enter my master password and find the password and copy it and close the keychain.

    6. Enter the password and it takes me back to the comment form. I click the “submit” button and the comment will not post. I can click the submit button all day long and nothing. Zero, zip, nada.

    7. Force refresh the page, re-enter the comment (if I was thinking clearly I copied the comment content, otherwise I have to retype it), re-enter my email address (still logged into wordpress at this point so why should I have to re-enter my email address?) and click submit and then the comment posts.

    Does AutoMATTic really think people are going to go through all this just to leave a comment on a wordpress.com site? Seriously?

    The awesomeness [sic] of this is truly amazing. I can’t wait to see what awesomeness the future holds.

    #850300

    shoreacres
    Member

    @thesacredpath – Completely OT, but if you don’t know what happened to ellaella, I received this word today.

    #850301

    @shoreacres, thanks so much for letting me know. I’ll pass it around to the people I knew who were online friends with her.

    #850302

    timethief
    Member

    @shoreacres
    Thanks for the link (she said through her tears). :(

    #850304

    @roaringforties, I agree about having a better explanation on the error page. We’re working to make the entire process better.

    #850309

    @thesacredpath, the first part of your reply is good feedback, thank you for posting it! We are working to make it better. I’m sorry it’s been frustrating!

    Note for blog owners: you can uncheck the “Comment author must fill out name and e-mail” option on your Settings → Discussion page and that will allow anyone to leave a comment without needing to enter their email address. That option might be helpful to some of you in the short term.

The topic ‘commenting bugs’ is closed to new replies.