Comments going straight to trash for no reason

  • Author
    Posts
  • #3353712

    On Monday, I found 169 comments in the trash dating back months!! Some comments are being put in the trash even though I have nothing set to do that kind of behavior, not in my spam plug-in (Cleantalk) or the Discussion settings.

    On my site’s backend, there is nothing listed under Comment Moderation or Comment Blacklist. The comments are perfectly fine, not spam, and just seem to end up in the trash for no reason, which forces me to ‘Restore’ them and then Approve them.

    After restoring/approving ALL of them (all were from trusted users and not spam), I found three more in the trash from over the weekend.

    I finally logged into WordPress.com where my site is connected for JetPack and social sharing and under Site > Settings > Discussion, I found a bunch of gobbledygook characters under the Comment Moderation list and a ton of words in the Comment Blacklist section. It has words on the blacklist that aren’t even dirty and have other definitions, like “enhancement”.

    Here are just a few of the characters under Blacklist, not to mention a ton of words:
    д
    и
    ж
    Ч
    Б
    [url=
    [/url]

    I highlighted them all, deleted them, it says Settings Saved, but when I go to leave the page it gives me a warning that I have unsaved settings and whether I’m sure I want to leave. I save again, try to leave, this time I click “Yes” I want to leave, and when I come back all the WORDS are back in the lists.

    Why is WordPresss.com overriding my own admin backend’s comment settings on my site hosted at a different company? I only use WordPress.com for JetPack and social sharing.
    How do I permanently get rid of those words that are sending perfectly normal comments to the trash?

    The blog I need help with is climatechangedispatch.com.

    #3353834

    Hi –

    You’ll want to inquire about this in the forums dedicated to sites that use the WordPress.org open source software. That’s quite different from what we do here at WordPress.com which is a managed hosting environment.

    Head over to https://wordpress.org/support/forums/ or contact your plugin team directly.

    #3353845

    The comment blacklist is being filled in by WordPress.com, not my site. It’s only connected because JetPack requires it. My WordPress backend shows both the Comment Moderation and Comment Blacklist filled are blank.

    But if I log into WordPress.com, it shows the lists filled with words and gobbledygook characters (see my original post). I can’t even delete them as it refuses to save the settings. How is that not your problem? Are you saying this is the fault of the JetPack plugin? That makes no sense.

    Also, there was a topic discussed on this very thing happening at WordPress.org. They were told that it was a WordPress.com issue. And they closed the discussion.
    https://wordpress.org/support/topic/comments-going-straight-to-trash/

    #3353897

    Thanks for coming back to us. I am looking at this now and will report back with what I can figure out.

    #3353898

    Alright. Are you able to edit those words by clicking on

    Jetpack -> Settings -> Discussion

    See here: climatechangedispatch.com

    Since the site is not hosted on WordPress.com we don’t have any access to it but will do our best to help. I don’t want to flip flop you around place to place. Give that a try and write back to me here with an update.

    #3353911

    The words aren’t listed in the JetPack plugin. They are listed in the WordPress.com backend. That is to say, your website’s backend for my site.

    Here’s a link to a screenshot of the WordPress.com backend.
    https://climatechangedispatch.com/wp-content/uploads/2019/08/wp-backend.jpg

    It’s literally a duplicate of my site’s backend but with a different theme. Except I can’t get rid of any of those words in either list.

    They’re blank on my site’s backend. Here’s a screenshot of my site’s Discussion settings:
    https://climatechangedispatch.com/wp-content/uploads/2019/08/ccd-backend.jpg

    Here is a screenshot of the Jetpack > Settings > Discussion:
    https://climatechangedispatch.com/wp-content/uploads/2019/08/jetpack-backend.jpg

    Thanks for your help. If you need more screenshots, let me know.

    #3353972

    macmanx
    Staff

    I do see a general sync error between your site and us: https://jetpack.com/support/debug/?url=https%3A%2F%2Fclimatechangedispatch.com%2F

    I suspect that’s the cause, but I don’t see anything outright that would be causing that.

    I recommend contacting Jetpack Support about this via https://jetpack.com/contact-support/?rel=support

    #3366389

    Hi all,

    Since this is a public topic, we’d like to give more info, then it may be helpful for other people in the future :)

    After troubleshooting, it turned out that the cause is from a plugin called “Bluehost” or “MOJO”. Feel free to contact Bluehost or simply disable it.

    – File: /wp-content/plugins/mojo-marketplace-wp-plugin/vendor/bluehost/endurance-wp-module-spam-prevention/spam-prevention.php

    – Screenshot: https://user-images.githubusercontent.com/10045087/64411607-c7220980-d0b7-11e9-8a26-f7b4a0b75a0b.png

    #3366437

    Yes, thanks to Jetpack for their help in solving this riddle. It’s called the MOJO Marketplace plugin (available at wordpress.org’s plugin repository) that a lot of hosting companies include by default.

    I’ve since deactivated the plugin (and deleted it) and the problem hasn’t returned. Many thanks to the ‘happiness engineers’ at Jetpack for getting to the root cause of this.

The topic ‘Comments going straight to trash for no reason’ is closed to new replies.