comments just wont turn on!

  • Author
    Posts
  • #373560

    rpboggs
    Member

    Sorry if this a repeat question – but I am just not being able to turn comments on for my posts! I have tried everything from turning it on globally from the settings –> discussion to turning comments on individually for the posts by checking “Allow Comments” box and for some reason nothing seems to work! Please…any help would be appreciated….much appreciated!

    The blog I need help with is btsblogs.wordpress.com.

    #373711

    The site linked to your username is not a wordpress.COM blog. If you are talking about a wordpress.COM blog, then we need a link please.

    #373712

    rpboggs
    Member

    Oh oops sorry – the blog is:
    http://btsblogs.wordpress.com/

    #373714

    If you had comments turned off for a while, any posts made during that time will have the comments disabled on each post. The global setting when comments are off, simply turns comments off automatically post by post as you make new posts.

    1. Go to settings > discussion and turn comments on.
    2. Go to the posts > edit page in the dashboard, click on the checkbox at the left end of the bluish-grey top bar above the post list to select all posts on that page. Go to the “bulk actions” pulldown and select “edit” then click “apply.”
    3. Go to the comments pulldown toward the left and select “allow” and click “update posts.”

    Do that for each page of posts made while the comments were turned off globally.

    #373716

    rpboggs
    Member

    Tried that too – didn’t work – still shows up as Comments Off :(

    #373717

    If you have comments turned on globally, open your latest post for edit and in the “discussion” section, turn comments on and then click “update post” and post back here after that so that I can take a look.

    #373718

    rpboggs
    Member

    Well weird thing – any new posts I do, the comments show up – but not on the old/existing posts.

    #373719

    Open up each older post, go to the discussion section and allow comments, then click update post.

    #373720

    rpboggs
    Member

    I did that – and here is the post:
    http://btsblogs.wordpress.com/2009/05/28/the-holy-grail-of-fitness/

    Still shows up comments off.

    #373721

    rpboggs
    Member

    Stupid thing man – doesn’t do anything for the older posts – but any new posts, works perfect and I can turn comments on and off. Too much work to figure it out – i think i’m just gonna create a new post and copy from the older posts – its just one article anyways. Thanks!

    #373722

    rpboggs
    Member

    OOOh I think I figured it out – it has something to do with categories. For example – I only had one category on the blog called “Everything BTS” and deleted the others – but somehow a new category called “1” is created automatically. Now if I assign the post to the category “1” – it works fine – but as soon as I assign to “Everything BTS” the comments turn off automatically.
    Makes sense?
    Doesn’t to me :P

    #373723

    I just did a test. I turned comments off globally, created three test comment and published them, then turned global comments back on. The comments I made while global comment was turned off did not have comments enabled.

    I then went to posts > edit, selected the three comments, chose bulk actions > edit, clicked “apply” and selected “allow comments” then clicked the update button. Now the three test comments have comments on.

    If that didn’t work for you, then there is either a step missing in your process or there is an issue with your blog and you might have to contact staff directly at http://support.wordpress.com/contact/ . The volunteers here in the forums do not have access to the back end so we cannot go into your dashboard to check things.

    What browser / browser version are you using by the way?

    #373724

    rpboggs
    Member

    I tried IE 7 and Firefox 3 – and wasn’t getting anywhere – but its fixed now. Just had to do a simple work around. Wish I had thought of this 2-3 hrs earlier.
    Thanks for the help though.

    #373725

    You’re welcome. The process I outlined should have worked just fine and I’m confused as to why it would not. Glad you are back up and running though.

The topic ‘comments just wont turn on!’ is closed to new replies.