Contact Form is breaking

  • Author
    Posts
  • #742867

    raincitywest
    Member

    Hi there,

    I tried to edit my form last night and in the builder it will look great. Once I save and publish, the form looks horrible. When I go to edit, there are strange chararcters in the code or the form will add another form. Check out my blog and you will see. This is the main contact area for my business and right now our business looks horrible. Please help. Code below:

    ‘[contact-form subject="Rain City West Printing Get A Quote" to="(email redacted)"] [contact-field label="Name" type="name" required="true" /] [contact-field label="Email" type="email" required="true" /] [contact-field label="Phone Number" type="text" required="true" /] [contact-field label="# of Shirts needed?" type="text" /] [contact-field label="Placement of print?" type="select" options="Front Center,Front Left,Back,Right Sleeve,Left Sleeve,Tags,Other" /] [contact-field label="# of colors in print?" type="select" options="One,Two,Three,Four,Five,Six" /] [contact-field label="Color of shirts?" type="text" /] [contact-field label="Shirt type?" type="select" options="Unisex,Mens,Ladies,Youth" /] [contact-field label="Size of shirts (S, M, L, XL) and # of each size?" type="textarea" /] [contact-field label="Do you have artwork?" type="select" options="Yes,No" /] [contact-field label="How did you hear about us?" type="select" options="Search Engine,Facebook,Twitter,Yelp,Yellow Pages,Friend" /] [contact-field label="Comments or Special Instructions" type="textarea" /]‘

    The blog I need help with is raincitywest.com.

    #742964

    auxclass
    Member

    When I pasted your code into my test site things broke – when I pasted into a text editor some things were missing but not the same errors as on my test site – something with the forms editor did not seem to be working – the code below is what worked on my test site –

    the question is if I can paste it into here OK – – – a side note – turn off the comments etc. on the forms page – try the below code – just past into a Page / Post

    [contact-form]
    [contact-form subject="Rain City West Printing Get A Quote" to="(email redacted)"]
    [contact-field label="Name" type="name" required="true" /]
    [contact-field label="Email" type="email" required="true" /]
    [contact-field label="Phone Number" type="text" required="true" /]
    [contact-field label="# of Shirts needed?" type="text" /]
    [contact-field label="Placement of print?" type="select" options="Front Center,Front Left,Back,Right Sleeve,Left Sleeve,Tags,Other" /]
    [contact-field label="# of colors in print?" type="select" options="One,Two,Three,Four,Five,Six" /]
    [contact-field label="Color of shirts?" type="text" /]
    [contact-field label="Shirt type?" type="select" options="Unisex,Mens,Ladies,Youth" /]
    [contact-field label="Size of shirts (S, M, L, XL) and # of each size?" type="textarea" /]
    [contact-field label="Do you have artwork?" type="select" options="Yes,No" /]
    [contact-field label="How did you hear about us?" type="select" options="Search Engine,Facebook,Twitter,Yelp,Yellow Pages,Friend" /]
    [contact-field label="Comments or Special Instructions" type="textarea" /]

    [/contact-form]

    #742965

    auxclass
    Member

    Well – mostly worked – the [/contact-form] seems to have gotten separated but you need it at the end –

    Something does seem to be funny with the forms editor this morning.

    Worth a complaint to the support staff even if my code for you above works

    http://en.support.wordpress.com/contact/ – search on anything then page down for the contact form

    off subject – any relation to Rain City Video? Probably would have been quicker for me to walk over :)

    good luck

    #743033

    macmanx
    Staff

    It looks like you had entered a few fields more than once. I’m not exactly sure how that attributed to the odd display, but I removed them and it looks just fine now.

The topic ‘Contact Form is breaking’ is closed to new replies.