"Continue reading" problem

  • Author
  • #648064

    I want the full text of a post to appear, rather than the first couple of lines then “continue reading”. I’ve looked through the other answers which seem to point to a more tag, but when I view the HTML behind my posts, I can’t see this tag.

    Looking at my blog, if you click one of the links down the right-hand side, you’ll see a few lines of text appear with “continue reading” at the end of it. If you then click that “continue reading” link, you get the full post. I want the full post to appear first, rather than just a preview.

    Thanks in advance.

    The blog I need help with is chasingthehypotenuse.wordpress.com.



    The Read More in your case is working as designed – that is the way the Posts are displayed when you request a list of all Posts (stories) for a given category. That is to prevent your pages from going on forever. It a category for instance had many long Posts your visitors would never find the bottom Post.

    You should also consider using the Contact Form http://en.support.wordpress.com/contact-form/ to get your email off the site and away from spam bots. The form can be customized so you can ask for a bit of information from anyone that wants a password to read a full story.


    Many thanks for the speedy response and for the suggestion about the contact form.

    RE the Continue Reading link – each category only has one post so the issue you describe above won’t occur. Is there no way to remove this link and display a post in full?



    I am not aware of any way to remove the read More when you are doing a sort on a Category.

    You could use a Recent Posts Widget in the sidebar and that would list up to I think the last 12 Posts.

    A Text Widget might also work for a long list of many Posts (stories)


    @chasingthehypotenuse: For full posts on archive pages, copy the whole content of each post from the HTML editor, paste it into the Excerpt module of the editor, click Update.
    If you’re not seeing an Excerpt module while on the post editor screen, click Screen Options (top right) to activate it.



    I learn something new every day



    Thank you so much! One last question (I hope) – how do I get rid of the “continue reading” link, which is still showing at the bottom of the (now complete) text?

    Thanks again.



    Edit and and remove it.



    OOPS! Ignore that comment I made. The reason we use excerpts is so that the “read more” link will appear and it can be clicked to view the whole post or page on its individual page will appear. The software is providing that link.


    Ah ok. Thanks anyway.



    I’m sorry I entered this thread as I may have confused you and that was not my intention.


    No, not at all! Thank you for trying to help – I’m just frustrated as I’ve been trying to get this to work for days now and it seems that there isn’t any way to remove that link.

    Thanks again all of you for your comments – much appreciated.

The topic ‘"Continue reading" problem’ is closed to new replies.