Copy a post

  • Author
    Posts
  • #3237426

    scottqmarcus
    Member

    I can no longer copy a post. When i use the old version of wp.com, it says ‘copy a post’ on the dashboard but it doesn’t do anything. I was using the ‘blue’ version where I could click ‘edit’ and on the bottom it showed ‘copy’ but now, under this new version, that’s not even available. I lived on that feature. Any ideas?

    The blog I need help with is thistimeimeanit.com.

    #3237432

    nikolnieto
    Member

    Hi! Is this site you need help with thistimeimeanit.com?

    If so, it looks like you’re using a self-hosted WordPress.org setup. Note the difference: WordPress.com and WordPress.org

    This is a support forum for sites hosted here on WordPress.com. So you’ll need to post on the WordPress.org Support Forums for help. You may need to create an account over there if you don’t have one already. 🙂

    #3237434

    scottqmarcus
    Member

    No, I’m not referring to the site your referenced. I also do some work for a non-profit and they have the free version (wordpress.com). The site I’m working on for them is https://eurekaparksandrec.wordpress.com/

    Even when I click the “duplicate” or “copy” link, all it does now is give me a blank page.

    #3237437

    nikolnieto
    Member

    Oh, I see.

    I just tried to reproduce this issue and I’m having the same problem. Selecting ‘Duplicate’ on a post in https://wordpress.com/posts/ just opens a new, blank post. The only thing that seems to have been copied over is the timestamp.

    I’m going to tag this with modlook. Hopefully, staff can shed some light on this or file a bug report.

    #3237438

    scottqmarcus
    Member

    Thank you; I appreciate it.

    It’s been going on for a long time with the super old version. It was fine with the ‘blue’ version; however the ‘blue” version didn’t give me the ability to edit the size of images (i could only crop them). So, I’d go to the “blue” version; select ‘duplicate,” and then go back to the old version and make the changes I needed to make and the post. Now, I can’t even do that.

    #3237533

    kokkieh
    Staff

    Hi there,

    I see you have the new block editor enabled on that site. The Copy Post feature is not supported in that editor yet, but we are working on adding it.

    For now, to use the copy post feature you’ll need to complete deactivate the block editor and use the classic editor instead. You can see here how to switch back to the classic editor:

    https://en.support.wordpress.com/wordpress-editor/#faq

    #3243577

    kokkieh
    Staff

    Hi there,

    The ability to copy a post has now been added for the block editor. That option is not in the editor itself, but instead to use it go to My Site ->Blog Posts or My Site ->Pages, click the … icon for the post/page, and then click the Duplicate/Copy option to create a new post/page that is a copy of the existing one.

    Let me know if you run into any trouble with this.

    #3248598

    scottqmarcus
    Member

    Thank you for fixing this. Makes my life so much easier.

The topic ‘Copy a post’ is closed to new replies.