Custom font not displaying on mobile

  • Author
    Posts
  • #3298614

    d3anna33
    Member

    I am creating a website with the premium WordPress package, and the Hammer theme. I have many nice custom fonts to choose from and have been trying to use one for my site title. They will show on Safari, but when I view my website on Chrome on mobile the custom font doesn’t display and shows as a plainer font.

    I googled the issue and read that it is due to custom fonts being available on all browsers, so tried to see if I could link to a google font in my CSS customisation area, but it is not working. Not sure if it is not possible, or if I am doing it wrong.

    Is there any way to get my custom font (or any custom font), to display on mobile, when all I can access is CSS editing?

    The blog I need help with is d3anna33.wordpress.com.

    #3299125

    Hey,

    You can only use the fonts from the Fonts section in the Customizer, based on the package you’re using. If you want to use a custom font, you need to have a business plan (see https://en.support.wordpress.com/custom-fonts/#frequently-asked-questions).

    I added the modlook tag to this topic so one of the WordPress staff can have a look at this. In the meantime, it would be great if you could attach some more details about how you managed to add the custom font to the site title and make it work in Safari. Also, a few screenshots from both Safari and Chrome would be great, in order to see exactly what’s the difference.

    #3299169

    fstat
    Staff

    Hi there,

    For a font to be displayed it must be installed on that computer/device. If that font is not installed, then a similar one is displayed.

    Can you please send us some screenshots from both your computer and your phone to better evaluate the issue? You can use a tool like https://snag.gy/ to quickly grab a screenshot.

    #3299550

    Hi, I am facing multiple issue in my website:

    1) Bold is not working:
    I have applied Bold to multiple text in multiple posts but it is not working anywhere, I am not sure why. I tried checking it from Inspect Element but it clearly shows tag applied but it is not making the text bold.
    Here is the screenshot of Inspect Element:
    https://prnt.sc/n6rfxy
    Post I am referring to:
    https://dailysportsupdates.com/icc-cricket-world-cup-2019-schedule/
    Problem is not just on this page but it is on all my posts.

    Theme: Genesis Framework
    Child Theme: Metro Pro

    This is so frustrating as I bought premium Theme and can’t even do these little things.
    I have tried searching it on web but didn’t find any clue. If I am doing it wrong then please indicate. I would appreciate if you guys can help me with the exact code to put in additional css to make it work Or Any Plugin?

    Thanks

    #3299648

    kokkieh
    Staff

    @talhakhanbaloch

    Please don’t post into other people’s threads.

    Your site is also not hosted with us on WordPress.com, but using the open source WordPress.ORG software at another host. You have never bought anything from us on WordPress.com.

    Please contact support for your theme directly for help with this.

The topic ‘Custom font not displaying on mobile’ is closed to new replies.